Windows Admin Center Preview 1812 is now available!


In this release of Windows Admin Center Preview, we've added power configuration to server settings, BMC info (for IPMI-compatible BMCs), Dark UI theme (preview, work in progress), and the ability to manage your connection list and extensions with PowerShell.


Read the official announcement here:

7 Replies


Can you tell me how the IPMI/BMC should show up ?

I have HP physical servers where IPMI is functional (I tested this with IPMIPing), the iLOs are fully configured and working as desired but in WAC on the overview tab it doesn't show up.

The client from where I access WAC and the server running WAC can do the IPMIPing successfully.


Thanks in advance for your help

Hi Marc!

Can you run the following PS script on the HP server and let me know what results you get? Thanks!


$bmcInfo = Get-PcsvDevice
$result = New-Object -TypeName PSObject
$result | Add-Member -MemberType NoteProperty -Name "Ip" $bmcInfo.IPv4Address
$result | Add-Member -MemberType NoteProperty -Name "Serial" $bmcInfo.SerialNumber

Hello Daniel,

Thanks for your answer.

I tried Get-PcsvDevice -TargetAddress X.X.X.X -ManagementProtocol IPMI -Credential $mycred

where X.X.X.X is the IP of the iLO but it gives me an error :

Get-PcsvDevice : The operation failed. The device returned the following RMCP+ status code: 9.


I tried that on mutliple servers with always the same result and I can't find information about this error.

I will have to investigate this issue.



Hello Daniel,

Sorry to bother you with that but I am suely missing something but I can't get it to work.

Whatever I try with get-pcsvdevice, I have always the same error.

The error is : 

Get-PcsvDevice : The operation failed. The device returned the following RMCP+ status code: 9.
At line:1 char:1
+ Get-PcsvDevice -TargetAddress -Credential $mycred -Managemen ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: ( [Get-PcsvDevice], CimExce
+ FullyQualifiedErrorId : MI RESULT 1,Get-PcsvDevice


I have found a tool here  and when I use it, it works !

When I try ipmiutil I get :

PS C:\Users\ext553\Downloads\ipmiutil-3.1.3-win64> .\ipmiutil.exe health -N -U xxxxxxxxx -P xxxxxxxxxx
ipmiutil health ver 3.13
Connecting to node
ipmilan_open_session error, rv = -15
ipmilan BMC only supports lan v2
Opening lanplus connection to node ...
BMC manufacturer  = 00000b (HP), product = 2000 (Proliant ML/DL)
BMC version       = 2.61, IPMI v2.0
IPMI driver type  = 9        (lan2)
Selftest status   = 0055     (OK)
Chassis Status    = 21 00 40 00 (on, see below)
        chassis_power       = on
        pwr_restore_policy  = last_state
        chassis_intrusion   = inactive
        front_panel_lockout = inactive
        drive_fault         = false
        cooling_fan_fault   = false
Power On Hours    = 41353 hours (1723 days)
BMC LAN Channels  = 2
Chan 2 AuthTypes  =
ipmiutil health, completed successfully


So there should be no problem with the server itself but with the cmdlet, don't you think ?


Thanks in advance for your help




Jeff, This is great news. Any chance of turning WAC in to a PWA app or a .net core app using a wrapper to allow it to run on any OS using ReactXP ?

There is no current plan on releasing Windows Admin Center as a PWA/electron/etc standalone app.


Here's the suggestion on uservoice, add your vote to help us track interest!

@Jeff Woolslayer 

Just a quick question, is ther a reason why certain characters cannot be typed when using the rdp in browser? characters like : and - just aren't typed in and ignored leaving me to have to use the osk for them. not a huge deal but just wondering. Also, Is there any way to keep connections persistent? Sometimes when i open wac from a new place i lose all of my connections, and just today i had them all disappear from a pc i use frequently for wac