Windows Admin Center - Nexus Repo

%3CLINGO-SUB%20id%3D%22lingo-sub-1413505%22%20slang%3D%22en-US%22%3EWindows%20Admin%20Center%20-%20Nexus%20Repo%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1413505%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3EWe%20are%20implementing%20Windows%20Admin%20Center%20servers.%26nbsp%3B%20%26nbsp%3BThe%20WAC%20servers%20will%20not%20have%20internet%20access%20to%20install%20Extensions%20from%20the%20URL.%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3EWe%20are%20looking%20at%20using%20our%20Nexus%20environment%20to%20host%20the%20extensions%20internally.%26nbsp%3B%20%26nbsp%3BIt%20appears%20this%20configuration%20is%20supported%20%22%3CSPAN%3ENuGet%20feed%20that%20supports%20the%20NuGet%20V2%20APIs%22.%26nbsp%3B%20%26nbsp%3BWe%20have%20not%20been%20successful%26nbsp%3Bin%20implementing%20this%20configuration.%26nbsp%3B%20We%20have%20tried%20the%20various%20repo%20types%20but%20they%20all%20fail%20with%20a%20invalid%20nuget%20feed%20error.%3CBR%20%2F%3E%3CBR%20%2F%3EDoes%20anyone%20have%20any%20guidance%26nbsp%3Bfor%20setting%20up%20WAC%20to%20use%20a%20Nexus%20repo%3F%26nbsp%3B%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3EThank%20you%3CBR%20%2F%3EBryan%3CBR%20%2F%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1442479%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Admin%20Center%20-%20Nexus%20Repo%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1442479%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20were%20able%20to%20get%20Nexus%20to%20work.%26nbsp%3B%20We%20had%20to%20create%20a%20Nuget%20Repo%20group%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%20class%3D%22x_MsoNormal%22%3EThe%20setup%20for%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%20class%3D%22mark32ltv1fj6%22%3ENexus%3C%2FSPAN%3E%3A%3C%2FP%3E%3CP%20class%3D%22x_MsoNormal%22%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3ECreate%20a%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%20class%3D%22mark32ltv1fj6%22%3Enexus%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Egroup%20repo%3C%2FLI%3E%3CLI%3ECreate%20a%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%20class%3D%22mark32ltv1fj6%22%3Enexus%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Enuget%20repo%3C%2FLI%3E%3CLI%3EAdd%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%20class%3D%22mark32ltv1fj6%22%3Enexus%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Enuget%20repo%20to%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%20class%3D%22mark32ltv1fj6%22%3Enexus%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Egroup%20repo%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLI%3E%3C%2FOL%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Hello,

We are implementing Windows Admin Center servers.   The WAC servers will not have internet access to install Extensions from the URL.


We are looking at using our Nexus environment to host the extensions internally.   It appears this configuration is supported "NuGet feed that supports the NuGet V2 APIs".   We have not been successful in implementing this configuration.  We have tried the various repo types but they all fail with a invalid nuget feed error.

Does anyone have any guidance for setting up WAC to use a Nexus repo?  


Thank you
Bryan


1 Reply
Highlighted

We were able to get Nexus to work.  We had to create a Nuget Repo group

The setup for Nexus:

 

  1. Create a nexus group repo
  2. Create a nexus nuget repo
  3. Add nexus nuget repo to nexus group repo