WAC Not displaying CPU or Memory usage correctly

Copper Contributor

We are having an issue with our WAC gateway where all our Azure Stack HCI clusters CPU and Memory usage is 0 with a total of NaN%, also the servers do not display memory or CPU:



I cant seem to figure this issue out, not sure what I should do next.



16 Replies

@David_Smith040 Same problem here. WAC in Client and Gateway Mode. Same Issue...

Did you find any solution?


Version: 2110.2 - Build: 1.3.2204.19002





Not yet I'm afraid, I have submitted the issue to WAC github page also, good to know I might not be the only one!

I might have to tweet at them next... I have even tried WAC from Azure also same issue.

Are you seeing this issue on a Azure Stack HCI Cluster? 

Yes, on a Azure Stack HCI (current release, not preview channel).


We're facing the exact same issue.

Let me know if you have any update please :)




I am having the same issue.

Have beat it up in troubleshooting quite a bit.

Opened a case with MS Azure support 60 days ago, no real guidance at all on the matter.

My AHCI cluster is effectively non-functional because of this.

Considered this transition from 2019 S2D two node cluster earlier this year through a 60 day trial evaluation and trial, where I upgraded/tested the solution successfully.

Something has changed since then that caused these components to break.

I went ahead and tweeted @azure today to escalate.
Perfect, I have been waiting to see if this fix it in the next release, let us know how you get on!
We're also seeing this same issue on Azure Stack HCI OS 21H2.

Update for everyone on this issue. I tweeted the CEO of Microsoft today because I had no response on my other escalations. I was informed the same day (no surprise) that they are in fact working on a fix for an issue I reported regarding Bitlocker and Deduplication status (60 days ago), which I believe may be related. I am experiencing this problem in the thread and the above. Will prompt support again RE this thread. Hold on tight kids! Honestly, hard to believe such a high level enterprise feature could just be "broken". Makes me want to go back to legacy solutions and management that "work" for the most part as described on a regular basis. In fact, I did last night, purged HCI and just went to regular HyperV and Storage Spaces for my NVME for the time being until this stuff is more mainstream. 

Thanks for taking the time to push this with Microsoft! Once I am done with my other tickets for MDE ill also open one for this.
Same Problem here with a Windows Server 2022 S2D Cluster

I was told by Microsoft support that they were working to deploy a fix this week. I requested confirmation this has been done, have not heard official word and no news about an update yet. Github has had a bug report for this open since earlier this summer around the time I opened my ticket. No traction on that either. 

@David_Smith040 Apparently I wanted more punishment, because I really want this config to work! I reconfigured my HCI cluster this week to test their reported fix via Windows update. Guess what? Still doesn't work, same result, as reported here, no CPU/RAM/Uptime status in cluster manager, no proper recognition of bitlocker or deduplication roles installed and supported on hosts. I would really like to know how we discover and correct the root cause of this issue. 

I have not installed the update just yet. I was meant to have a support call with them Thursday regarding this issue but they ghosted me... I'll email them again Monday.
Actually, I am having a Friday moment...I swear I checked for updates multiple times in WAC, it said there were no more updates! Went on the console through iPMI in SConfig...there were pending updates, I applied them....AND IT WORKED! Problem solved, I am seeing CPU/RAM/Uptime in WAC for my HCI cluster. I also checked and it seems to now detect bitlocker and depup roles. Very very thankful for the Microsoft team getting this one solved.

@mestabrookHi! would you mind sharing us which update you installed please? :) TIA, Regards

I believe its this one - KB5017381
after installing the KB on one of my HCI clusters the cluster is now displaying the correct data (I will do the others in a week or so to make sure everything is OK).