WAC extension install/update via proxy

%3CLINGO-SUB%20id%3D%22lingo-sub-953749%22%20slang%3D%22en-US%22%3EWAC%20extension%20install%2Fupdate%20via%20proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-953749%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20using%20WAC%201904.1%20GA%20on%20Windows%20Server%202016%20(Desktop%20Version).%20Our%20server%20doesn't%20have%20direct%20internet%20access%20because%20of%20security%20regulations%20-%20only%20via%20proxy%20(without%20authentication).%20Is%20this%20supported%20and%20how%20to%20configure%20this%3F%20Didn't%20find%20any%20setting%20not%20documentation%20on%20this.%20Any%20suggestions%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3EWolfgang%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-959812%22%20slang%3D%22en-US%22%3ERe%3A%20WAC%20extension%20install%2Fupdate%20via%20proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-959812%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F311075%22%20target%3D%22_blank%22%3E%40wbaeck%3C%2FA%3E%26nbsp%3BWindows%20Admin%20Center%20should%20use%20your%20OS-level%20proxy%20settings.%20Feel%20free%20to%20email%20smefeedback%40microsoft.com%20with%20details%20about%20your%20environment%20if%20this%20is%20not%20the%20case%2C%20and%20we%20can%20investigate%20the%20root%20cause.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAlternately%2C%20you%20can%20download%20the%20extensions%20from%20the%20public%20internet%20and%20host%20them%20internally%20using%20these%20instructions%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fmanage%2Fwindows-admin-center%2Fconfigure%2Fusing-extensions%23installing-extensions-on-a-computer-without-internet-connectivity%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fmanage%2Fwindows-admin-center%2Fconfigure%2Fusing-extensions%23installing-extensions-on-a-computer-without-internet-connectivity%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1036129%22%20slang%3D%22en-US%22%3ERe%3A%20WAC%20extension%20install%2Fupdate%20via%20proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1036129%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F57259%22%20target%3D%22_blank%22%3E%40Jeff%20Woolslayer%3C%2FA%3E%26nbsp%3BI%20have%20the%20same%20issue%20on%20WAC%201910%20on%20server%202019%2C%20server%20proxy%20set%20but%20WAC%20doesnt%20reach%20azure%20or%20extension%20feed.%20Is%20there%20things%20needed%20to%20be%20tweeked%20for%20WAC%20to%20be%20proxy%20aware%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ewac%20logs%20in%20eventlog%3A%3C%2FP%3E%3CP%3EFailed%20to%20set%20extension%20repository%20uri%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2Fsme-extension-feed%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2Fsme-extension-feed%3C%2FA%3E.%20Message%3A%20Unable%20to%20connect%20to%20the%20remote%20server%20StackTrace%3A%20at%20System.Net.HttpWebRequest.GetResponse()%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ebut%20browsing%20in%20i.e%3B%20IE%20to%20same%20url%20from%20server%20works%20fine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eproxy%20set%20in%20server%20settings%2C%20via%20netsh%20winhttp%20set%20proxy%20and%20in%20IE%20proxy%20settings.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi

 

We are using WAC 1904.1 GA on Windows Server 2016 (Desktop Version). Our server doesn't have direct internet access because of security regulations - only via proxy (without authentication). Is this supported and how to configure this? Didn't find any setting not documentation on this. Any suggestions?

 

Thanks

Wolfgang

2 Replies
Highlighted

@wbaeck Windows Admin Center should use your OS-level proxy settings. Feel free to email smefeedback@microsoft.com with details about your environment if this is not the case, and we can investigate the root cause. 

 

Alternately, you can download the extensions from the public internet and host them internally using these instructions: https://docs.microsoft.com/en-us/windows-server/manage/windows-admin-center/configure/using-extensio...

Highlighted

@Jeff Woolslayer I have the same issue on WAC 1910 on server 2019, server proxy set but WAC doesnt reach azure or extension feed. Is there things needed to be tweeked for WAC to be proxy aware?

 

wac logs in eventlog:

Failed to set extension repository uri https://aka.ms/sme-extension-feed. Message: Unable to connect to the remote server StackTrace: at System.Net.HttpWebRequest.GetResponse()

 

but browsing in i.e; IE to same url from server works fine.

 

proxy set in server settings, via netsh winhttp set proxy and in IE proxy settings.