Unable to install WMF 5.1 on Server 2008 (not R2)

%3CLINGO-SUB%20id%3D%22lingo-sub-1400034%22%20slang%3D%22en-US%22%3EUnable%20to%20install%20WMF%205.1%20on%20Server%202008%20(not%20R2)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1400034%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20been%20trying%20to%20install%20WMF%205.1%20on%20some%20older%202008%20Servers%20(they%20are%20not%20R2)%20so%20that%20I%20can%20use%20Storage%20Migration%20Services%20in%20WAC%201910.%26nbsp%3B%20So%20far%20I%20have%20been%20unsuccessful%20and%20all%20the%20documentation%20I%20have%20found%20refers%20to%202008%20R2%20(I%20have%20some%20of%20these%20too%20but%20they%20have%20installed%20WMF%205.1%20successfully).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECurrently%20the%20servers%20have%20WMF%20core%20(Posh%202.0)%20and%20when%20I%20try%20to%20run%20the%20script%20that%20installs%26nbsp%3BWin7AndW2K8R2-KB3191566-x64.msu%20I%20get%20an%20error%20that%20I%20need%20to%20check%20the%20requirements%20or%20that%20it's%20not%20supported%20on%20this%20system.%26nbsp%3B%20The%20only%20requirements%20that%20I%20could%20find%20refer%20to%20.NET%20Framework%204.5.2%20or%20greater%20be%20installed%20(which%20I've%20done).%26nbsp%3B%20Has%20anyone%20else%20had%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1424502%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20install%20WMF%205.1%20on%20Server%202008%20(not%20R2)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1424502%22%20slang%3D%22en-US%22%3E%3CP%3EI%20found%20a%20way%20around%20this%20issue.%26nbsp%3B%20Installing%20WMF%205.1%20is%20necessary%20if%20you%20are%20trying%20to%20manage%20the%20server%20in%20WAC%2C%20but%20it%20is%20not%20necessary%20to%20use%20storage%20migration%20services.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20created%20jobs%20for%20those%20older%202008%20(non-R2)%20servers%2C%20ran%20inventory%2C%20validation%20and%20data%20transfer.%26nbsp%3B%20Now%20I%20have%20not%20done%20the%20cutover%2C%20but%20in%20my%20instance%20because%20this%20is%20such%20a%20huge%20company%20I%20will%20have%20to%20do%20that%20another%20way%20anyway%2C%20but%20coordinating%20with%20the%20data%20team%20that%20has%20rights%20to%20rename%20old%20and%20new%20servers.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I have been trying to install WMF 5.1 on some older 2008 Servers (they are not R2) so that I can use Storage Migration Services in WAC 1910.  So far I have been unsuccessful and all the documentation I have found refers to 2008 R2 (I have some of these too but they have installed WMF 5.1 successfully).

 

Currently the servers have WMF core (Posh 2.0) and when I try to run the script that installs Win7AndW2K8R2-KB3191566-x64.msu I get an error that I need to check the requirements or that it's not supported on this system.  The only requirements that I could find refer to .NET Framework 4.5.2 or greater be installed (which I've done).  Has anyone else had this issue?

1 Reply

I found a way around this issue.  Installing WMF 5.1 is necessary if you are trying to manage the server in WAC, but it is not necessary to use storage migration services.

 

I created jobs for those older 2008 (non-R2) servers, ran inventory, validation and data transfer.  Now I have not done the cutover, but in my instance because this is such a huge company I will have to do that another way anyway, but coordinating with the data team that has rights to rename old and new servers.