Storage migration service transfer speed and other issues

%3CLINGO-SUB%20id%3D%22lingo-sub-2897669%22%20slang%3D%22en-US%22%3EStorage%20migration%20service%20transfer%20speed%20and%20other%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2897669%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20using%20SMS%20to%20migrate%20a%20Windows%202008%20R2%20server%20to%20Windows%202019.%20I%20have%20WAC%20version%202103.2%20running%20on%20a%20fresh%20install%20of%20Windows%202019%2C%20fully%20updated.%20Both%20the%20source%20and%20destination%20server%20are%20running%20off%20the%20same%20vSphere%20ESXi%20host%2C%20both%20have%2010Gbps%20vmxnet3%20adapters%2C%20in%20the%20same%20subnet.%20The%20destination%20has%20the%20storage%20migration%20proxy%20feature%20installed.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoing%20the%20inventory%20of%20the%20files%20on%20the%20source%20server%20took%20several%20hours.%20The%20source%20size%20is%20998GB%20and%20roughly%203%20million%20files.%20I%20have%20the%20transfer%20running%20right%20now%20and%20it's%20been%20going%20on%20for%20the%20past%207.5%20hours.%20Looking%20at%20the%20space%20usage%20on%20the%20destination%20server%2C%20it%20looks%20like%20there's%20still%2080GB%20left%20to%20copy.%20What%20is%20being%20used%20under%20the%20hood%20to%20copy%20the%20files%3F%20Looking%20at%20task%20manager%20on%20the%20destination%20server%2C%20I%20see%20receive%20running%20around%2020Mbps.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20disabled%20the%20antivirus%20on%20both%20servers.%20Source%20was%20running%20mcafee%20and%20the%20destination%20windows%20defender.%20On%20the%20destination%2C%20defender%20would%20use%20100%25%20of%20the%20CPU%20during%20the%20transfer.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELooking%20at%20the%20progress%20tab%20in%20WAC%2C%20there%20is%20no%20update.%20It%20says%20the%20speed%20is%200%20Bps%20and%20the%20process%20has%20been%20stuck%20at%2031.6%25%20since%20the%20beginning.%20Under%20transfer%20details%2C%20it%20says%20it%20processed%20315GB%20but%20in%20reality%20it's%20closer%20to%20800GB.%20Using%20the%20refresh%20button%20doesn't%20seem%20to%20change%20anything.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20using%20WAC%20to%20migrate%20this%20server%20because%20the%20permissions%20are%20a%20mess%20and%20several%20local%20groups%20are%20used.%20Another%20group%20is%20responsible%20for%20this%20and%20I%20am%20just%20trying%20to%20get%20rid%20of%20this%20windows%202008%20server.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20challenge%20now%20is%20to%20determine%20the%20correct%20maintenance%20window%20for%20the%20final%20synchronization.%20Given%20the%20unpredictable%20speed%2C%20it%20difficult%20to%20plan%20a%20meaningful%20change%20window.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhile%20troubleshooting%2C%20I%20came%20across%20a%20few%20post%20that%20showed%20Microsoft%20is%20eager%20to%20get%20feedback%20so%20I%20figured%20I%20would%20post%20here.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi,

 

I am using SMS to migrate a Windows 2008 R2 server to Windows 2019. I have WAC version 2103.2 running on a fresh install of Windows 2019, fully updated. Both the source and destination server are running off the same vSphere ESXi host, both have 10Gbps vmxnet3 adapters, in the same subnet. The destination has the storage migration proxy feature installed. 

 

Doing the inventory of the files on the source server took several hours. The source size is 998GB and roughly 3 million files. I have the transfer running right now and it's been going on for the past 7.5 hours. Looking at the space usage on the destination server, it looks like there's still 80GB left to copy. What is being used under the hood to copy the files? Looking at task manager on the destination server, I see receive running around 20Mbps.

 

I have disabled the antivirus on both servers. Source was running mcafee and the destination windows defender. On the destination, defender would use 100% of the CPU during the transfer. 

 

Looking at the progress tab in WAC, there is no update. It says the speed is 0 Bps and the process has been stuck at 31.6% since the beginning. Under transfer details, it says it processed 315GB but in reality it's closer to 800GB. Using the refresh button doesn't seem to change anything.

 

I'm using WAC to migrate this server because the permissions are a mess and several local groups are used. Another group is responsible for this and I am just trying to get rid of this windows 2008 server.

 

My challenge now is to determine the correct maintenance window for the final synchronization. Given the unpredictable speed, it difficult to plan a meaningful change window.

 

While troubleshooting, I came across a few post that showed Microsoft is eager to get feedback so I figured I would post here. 

 

Thanks

 

 

1 Reply
And I forgot to add, the WAC server is using 5.367 GHz of CPU while doing this. Now that I'm looking at this... does the data go from the source, through the WAC server and to the destination?