Storage Migration Service Hangs on Adding a Destination

Copper Contributor



Trying to migrate a file server from a Server 2016 instance to Server 2019 with Server Migration Service (SMS). I can get the inventory to complete (takes about 3 hours). When I move to the "Transfer data" stage, I can enter the credentials without issue. When I click "Next" to "Add a destination device...", the interface hangs while "Loading...." something. The "Include device" toggle is greyed out. (see attached, source server redacted).


I have let this run for about an hour and there was no change.


Source device has a number of shares (+40). The inventoried size is 8.54TB and the inventoried files is 1.91M. Quite a bit.



FS01: Source file server (WIndows 2016)

FS02: Destination file server (Windows 2019). VM with 2 Xeon E5-2620 CPUs, 8GB of RAM.

FS02: Orchestrator server

PC01: WAC (Windows 10 Professional 1809)


I have tried running the work using Edge and Chrome and get the same behavior. Load on FS02 is around 3% and very little RAM is being used.


The SMS debug log is recording the following errors

  • "Cutover configuration not found"
  • "GetTransferDeviceState request failed"
  • "Transfer was not run"
  • "GetCutoverDeviceState request failed"

Any insights or suggestions?

10 Replies

@ffries_nano I am having the same problem migrating from Server 2008 R2 to Server 2019. I was able to complete a migration on another server running the same OS, but have been stuck at Loading for this new migration. I have tried updating to the latest Windows Management framework on the 2008 R2 computer, tweaking firewall rules and making sure that Windows was up to date. 


Have you found a solution yet?





Hey  @bobbowlin,


I opened a ticket with Microsoft and they are looking into the problem. They gave an initial indication that this may be part of a known problem with Storage Migration Service, but have not yet confirmed.


Will pass along any insights.


Good luck on your end.




Same issue.  Was working fine before and please post if anything fixed your issue. 

@Dan H 


Same problem on multiple 2019 servers running Windows Admin Center.  This had been working fine for me a dozen times, but I had to uninstall/reinstall on one server and I updated to the latest version of Windows Admin Center(1904.1) and also updated my extensions for SMS, so I think it is one of those two.  Tried installing everything on a different 2019 server as well and using both Chrome and Firefox clients with same results.  I can add a device, scan it, enter in credentials, but when I get to next screen where I can normally add the destination both servers running WAC just hang with "Loading..." and never let me type.  This was working fine prior and will probably see if I can install an older version of admin center

I took a new server with 2019, all updates and 1904.1 and it failed in the exact same spot with "Loading...". after scanning a server with a lot of shares on it(someone else in this thread had mentioned the same)  So that was 2 servers with same issue with 1904.1 installed.  I then removed 1904.1 and installed 1809.5 and it fixed everything

@Dan Hthanks for digging. I'm running1809 on the destination server. I will say that my source server is not well configured (one of the reasons we are migrating), so in my case there may be more going on. I'm pushing forward with using other options to get the server migrated and fixed.


@ffries_nano @Dan H please open a support case with us to troubleshoot if this is happening in WAC or in SMS. We don't have others reporting this issue, we need to see your SMS logs and WAC debug, and that requires a support case.


Ned Pyle | Principal Program Manager, MS | @nerdpyle on twitter

Thanks @Ned Pyle, I have a case already open and folks have been looking at my logs. No answer yet and not sure if anything has been found yet.

Thanks @Ned Pyle 


We do not have a support contract with Microsoft and have to rely on these threads, but I took (2)servers and reverted them both back from 1904.1 to 1809.5 and it fixed both.  The server they were both having issues on with "Loading..." has 513 shares(do not ask).  We are moving again.

@Dan H Interesting. Did you continue to use the latest SMS WAC extension version and just switch to an older WAC?