Storage Migration Service - Cutover execution failed

New Contributor

I'm working on a test migration from a 2008R2 file server to a Server 2022 target.  I've done several migration attempts and am now stuck in a situation where I cannot begin a cutover.  I get the following errors in the StorageMigrationService-Proxy (Admin) log.


EventID 20502


Cutover pair failed.


Source Computer: <source server>

Destination Computer: <destination server>


Cutover stage: UnjoinSource

Error: -2147467261

Message: Object reference not set to an instance of an object.

Exception: at Microsoft.StorageMigration.Common.Util.GetQualifiedUserName(NetworkCredential credential) at Microsoft.StorageMigration.Proxy.Cutover.CutoverUtils.UnjoinDomain(NetworkCredential networkCredential, Boolean isLocal, String serverName, List`1 userCredentials, CancellationToken ct) at Microsoft.StorageMigration.Proxy.Service.Cutover.CutoverOperation.Run() .


Guidance: If possible, take action to prevent the last cutover error from happening and resume cutover. Alternatives include bringing the systems back to initial state before cutover has started and start cutover again.


Event ID 2504


Cutover execution failed.


Error Message: Object reference not set to an instance of an object.

Error: -2147467261

Exception: at Microsoft.StorageMigration.Proxy.Service.Cutover.CutoverOperation.Run() at Microsoft.StorageMigration.Proxy.Service.Cutover.CutoverRequestHandler.ProcessRequest(CutoverRequest cutoverRequest, Guid operationId)


I have tried initiating the migration from 3 different orchestration servers to 2 different targets and I still get the above errors.  I've tried performing SMS database resets on both the orchestration servers and the targets and still get the above error whenever I try a cutover.  The inventory & data-transfer are always successful.


I suspect I need to reset something on the source computer, but I don't know what I'm looking for.  Does anyone have any ideas?

4 Replies
I have the same problem! Were you able to find a solution?
Still working on it. I've tried deleting and re-creating the source, destination and orchestrator and still get the same error.


We're still waiting for a window to try it again, but I have some questions for you.


My Cutover failed at 30% with the same error, is that where you were in the process?


It sounds like you have tried quite a few things on the source, destination and orchestrator, have you tried anything on your domain controller?


What version of domain controller are you using? 

I haven't touched the domain controllers in all this. All our DC's are at Server 2019.