Extension Feeds - Unable to Remove Feed

%3CLINGO-SUB%20id%3D%22lingo-sub-1645945%22%20slang%3D%22en-US%22%3EExtension%20Feeds%20-%20Unable%20to%20Remove%20Feed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1645945%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3CBR%20%2F%3E%3CBR%20%2F%3EWe%20have%20been%20evaluating%20WAC%20for%20several%20months.%26nbsp%3B%20We%20have%20version%202007%20installed.%3CBR%20%2F%3EWe%20have%20a%20nexus%20repo%20feed%20working%20for%20several%20months.%3CBR%20%2F%3Eget-Feed%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Faka.ms%2Fsme-extension-catalog-feed%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2Fsme-extension-catalog-feed%3C%2FA%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdrpmga01.publix.com%2Frepository%2Fpblx_windowsadmincenter_ext_group%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fxxxxx.com%2Frepository%2Fxxxx_windowsadmincenter_ext_group%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%3CBR%20%2F%3ENow%2C%20I%20receive%20the%20following%20error%20when%20accessing%20Extensions%20under%20Settings.%3CBR%20%2F%3E%3CSPAN%3EError%3A%20The%20remote%20server%20returned%20an%20error%3A%20(404)%20Not%20Found.%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3EHowever%2C%20I'm%20not%20able%20to%20manage%20any%20Feeds%20Settings.%26nbsp%3B%20The%20options%20to%20manage%20the%20settings%20are%20grayed%20out.%3CBR%20%2F%3E%3CBR%20%2F%3EThis%20occurs%20on%20a%20desktop%20install%20of%20WAC%20and%20Server%20install%20(gateway).%3CBR%20%2F%3E%3CBR%20%2F%3EI%20uninstalled%2FInstalled%20WAC%20and%20was%20able%20to%20edit%20the%20Feed%20option.%26nbsp%3B%20Once%20I%20added%20a%202nd%20feed%20the%20error%20above%20logged%20again%20and%20I%20was%20no%20longer%20able%20to%20edit%20the%20Feeds.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20attempted%20to%20use%20PS%20to%20remove%20the%20FEED%20and%20it%20fails%20with%20the%20following%3A%3C%2FP%3E%3CP%3Envoke-WebRequest%20%3A%3CBR%20%2F%3E404%20-%20Nexus%20Repository%20Manager%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E(new%20Image).src%3D%22%3CA%20href%3D%22https%3A%2F%2Fxxxx.xxxx.com%2Ffavicon.ico%3F3.25.0-03%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fxxxx.xxxx.com%2Ffavicon.ico%3F3.25.0-03%3C%2FA%3E%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CBR%20%2F%3ENexus%20Repository%20Manager%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EOSS%203.25.0-03%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EError%20404%3CBR%20%2F%3ENot%20Found%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20Found%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EAt%20C%3A%5CProgram%20Files%5Cwindows%20admin%20center%5CPowerShell%5CModules%5CExtensionTools%5CExtensionTools.psm1%3A102%20char%3A17%3CBR%20%2F%3E%2B%20%24response%20%3D%20Invoke-WebRequest%20%40params%3CBR%20%2F%3E%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~%3CBR%20%2F%3E%2B%20CategoryInfo%20%3A%20InvalidOperation%3A%20(System.Net.HttpWebRequest%3AHttpWebRequest)%20%5BInvoke-WebRequest%5D%2C%20WebExc%3CBR%20%2F%3Eeption%3CBR%20%2F%3E%2B%20FullyQualifiedErrorId%20%3A%20WebCmdletWebResponseException%2CMicrosoft.PowerShell.Commands.InvokeWebRequestCommand%3CBR%20%2F%3EFailed%20to%20get%20the%20feeds%3CBR%20%2F%3EAt%20C%3A%5CProgram%20Files%5Cwindows%20admin%20center%5CPowerShell%5CModules%5CExtensionTools%5CExtensionTools.psm1%3A104%20char%3A9%3CBR%20%2F%3E%2B%20throw%20%22Failed%20to%20get%20the%20feeds%22%3CBR%20%2F%3E%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%3CBR%20%2F%3E%2B%20CategoryInfo%20%3A%20OperationStopped%3A%20(Failed%20to%20get%20the%20feeds%3AString)%20%5B%5D%2C%20RuntimeException%3CBR%20%2F%3E%2B%20FullyQualifiedErrorId%20%3A%20Failed%20to%20get%20the%20feeds%3C%2FP%3E%3CP%3EPS%20C%3A%5CWINDOWS%5Csystem32%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20another%20way%20to%20remove%20the%20Feed%20settings%3F%3CBR%20%2F%3EIs%20there%20a%20way%20to%20reset%20the%20WAC%20configuration%3F%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hello,

We have been evaluating WAC for several months.  We have version 2007 installed.
We have a nexus repo feed working for several months.
get-Feed
https://aka.ms/sme-extension-catalog-feed
https://xxxxx.com/repository/xxxx_windowsadmincenter_ext_group/


Now, I receive the following error when accessing Extensions under Settings.
Error: The remote server returned an error: (404) Not Found.

However, I'm not able to manage any Feeds Settings.  The options to manage the settings are grayed out.

This occurs on a desktop install of WAC and Server install (gateway).

I uninstalled/Installed WAC and was able to edit the Feed option.  Once I added a 2nd feed the error above logged again and I was no longer able to edit the Feeds.

I attempted to use PS to remove the FEED and it fails with the following:

nvoke-WebRequest :
404 - Nexus Repository Manager


(new Image).src="https://xxxx.xxxx.com/favicon.ico?3.25.0-03"

 

 

 

 

 

 


Nexus Repository Manager


OSS 3.25.0-03

 

 

Error 404
Not Found

 

Not Found


At C:\Program Files\windows admin center\PowerShell\Modules\ExtensionTools\ExtensionTools.psm1:102 char:17
+ $response = Invoke-WebRequest @params
+ ~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], WebExc
eption
+ FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeWebRequestCommand
Failed to get the feeds
At C:\Program Files\windows admin center\PowerShell\Modules\ExtensionTools\ExtensionTools.psm1:104 char:9
+ throw "Failed to get the feeds"
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : OperationStopped: (Failed to get the feeds:String) [], RuntimeException
+ FullyQualifiedErrorId : Failed to get the feeds

PS C:\WINDOWS\system32>

 

Is there another way to remove the Feed settings?
Is there a way to reset the WAC configuration?

 

 

0 Replies