Delegation to connect seems not working




WAC 1910 on Windows Server 2019 as a Gateway using Server Certificate from internal CA (Windows Firewall is disabled - when enable it, I could not connect at all although Firewall Rules for "Remote Service Management" is enabled, but this is different issue I delay ), I able to Add some Servers within the AD Domain, however could not connect to any of them, and always get "Specify Your Credentials" with Warning as "To Perform a single sign-in using your Windows account, you might need to set up Kerberos delegation",

I already created the required delegation using PowerShell command in documentation as below:

Set-ADComputer -Identity (Get-ADComputer node01) -PrincipalsAllowedToDelegateToAccount (Get-ADComputer wac)

+ nodes01 = target Server computer name

+ WAC = Windows Admin Center computer name


I tried on both Windows with Desktop & with Windows Core, and for both I have the same issue,

What can be the cause of the issue? and how can be solved?

1 Reply

BTW, if I ignore the delegation warning and click "Continue", I get different error as below:

"The client cannot connect to the destination specified in the request. verify that the service on the destination is running and is accepting requests..."

And "WINRM QC" shows that WinRM service is already running & setup for Remote Management"

Also I already allowed Remote Management using SCONFIG