[BUG] WAC 1910.2 - cannot enable role access and user connection to VM using browser

Copper Contributor

After installing Windows Hyper-V Server 2019 i installed WAC 1910 but after installing Windows Update was updated to 1910.2 when i try enable role base access i see this information:


At C:\Windows\Temp\WindowsAdminCenter.Jea\InstallJeaFeature.ps1:1 char:15 + Configuration InstallJeaFeature + ~~~~~~~~~~~~~~~~~ System.Management.Automation.PSArgumentException: Cannot process argument because the value of argument "fullFilePath" is not valid. Change the value of the "fullFilePath" argument and run the operation again. at Microsoft.PowerShell.DesiredStateConfiguration.CimDSCParser.GetFileContent(String fullFilePath) at Microsoft.PowerShell.DesiredStateConfiguration.CimDSCParser.ParseSchemaMof(String filePath) at Microsoft.PowerShell.DesiredStateConfiguration.Internal.DscClassCache.ImportClasses(String path, Tuple`2 moduleInfo, Collection`1 errors, Boolean importInBoxResourcesImplicitly) at Microsoft.PowerShell.DesiredStateConfiguration.Internal.DscClassCache.Initialize(Collection`1 errors, List`1 modulePathList) at Microsoft.PowerShell.DesiredStateConfiguration.Internal.DscClassCache.LoadDefaultCimKeywords(Dictionary`2 functionsToDefine, Collection`1 errors, List`1 modulePathList, Boolean cacheResourcesFromMultipleModuleVersions) at System.Management.Automation.Language.Parser.ConfigurationStatementRule(IEnumerable`1 customAttributes, Token configurationToken) At C:\Windows\Temp\WindowsAdminCenter.Jea\InstallJeaFeature.ps1:2 char:1 + { + ~ Unexpected token '{' in expression or statement. At C:\Windows\Temp\WindowsAdminCenter.Jea\InstallJeaFeature.ps1:69 char:1 + } + ~ Unexpected token '}' in expression or statement. At C:\Windows\Temp\WindowsAdminCenter.Jea\InstallJeaFeature.ps1:5 char:37 + [String] $ConfigurationId = 'localhost', + ~~~~~~~~~~~ The assignment expression is not valid. The input to an assignment operator must be an object that is able to accept assignments, such as a variable or a property.

I didn't found any fix for this


Another thing is that no matter witch browser user (i don't have old version od EDGE, only chromium version) i cannot user connect to VM by browse. To connect VM i need download RDP file :\

3 Replies

So we have now version 2007 and still that same problem :\

Did someone form WAC team even check this ?

@Prasidh_Arora i cen give you some insight about this bug after trying to resolve it.

For some reason no matter what i try "Get-DscResource" did not work on Windows Hyper-V server 2016 and 2019. 

Best thing is that i was able to install Role-Base on 18xx version of WAC but after upgrade it was impossible to do.


I tried install modules of DSCResources, PSDSCResources, xDSCResources and still not working :\ still "Get-DscResource" not present. Basically when i try type this i got error that this (in fresh installed OS)

The term 'Get-DscResource' is not recognized as the name of a cmdlet...

i tried to reinstall WMF 5.1 still no result :\

i tried to install modules and sill that same

So its related to DCS not present in other version of Windows Server then Essentials, Standard, Datacenter. I know that some variation of DSC is present in Nano server after reading in blog post and uservoice, more precise package "Microsoft-NanoServer-DSC-Package