Windows 11 unable to connect to update servers after fresh install.

Copper Contributor

Hi looking for advice before I throw my computer out the f*cking window. I’ve been trying to resolve issues with windows 11 updates for a solid 2 days. It started with windows not being able to run or update “NET Framework 3.5” (a requirement for Alan Wake) and install a windows intelligence update. I don’t think they are related but the windows update was the main issue. I tried everything I could find from support pages and forums and finally gave up and did a fresh install of windows 11 from USB. Now windows 11 boots up but the updates is still not working. It now says its unable to connect to the updates server. Annoyingly my MSI Z590 MOBO built in driver utility software doesn’t load up until after that initial post install windows update which means I must manually download all the drivers from the MSI website. And the NET Framework 3.5 still isn’t active. Also, I noticed my wired internet connect is inconsistent (no issues before the fresh install), but only with certain things; microsoft store, steam saying it cannot connect to servers and during the initial windows account setup it kept saying its lost internet. The chrome browser works fine so I assumed it was lack of drivers and updated all the intel drivers listed for my MOBO on the MSI website. But this hasn’t resolved the issue. It’s easier if I list all the things I’ve tried to resolve this “couldn’t not connect the updates server” listed in the windows update section of settings:

  • Restarting the Windows Update Service
  • Resetting Windows update components
  • Running Windows Update Troubleshooter
  • Running Internet Connections troubleshooter – no issues found
  • Changing my DNS Servers
  • Deleting the SoftwareDistribution Folder
  • Repairing Corrupted System Files
  • I don’t have Third-Party Antivirus Software, but I tried disabling windows firewall.
  • Deleting the Windows Update file cache
  • Checking Device Manager for errors
  • Checking the disk for corrupted sectors
  • Verifying my Internet connection
  • Doing a clean restart into Windows
  • Restoring and repairing system files
  • I have enough space on my C: drive for updates
  • Doing another fresh install but using a local account instead of my Microsoft account.

The only possible cause I can think off now is my product key for windows 11. I upgraded from a 500GB M.2 gen 3 to a 4TB M.2 gen 4 last week. I tried doing a partition clone using 3rd party software but long story short it didn’t workout and I had to do a fresh install of windows 11. In doing that I deleted the cloned partitions and created fresh ones for the windows install. After doing this I lost my windows 11 activation status and Microsoft wouldn’t give me my product key as they said I wasn’t covered for the changing in hardware. So, I bought a new one from CJS-CD keys and active the account with that instead. Seemed to work fine (green tick in the windows activated screen)  until this issue occurred with the security intelligence updating being stuck and throwing me down this rabbit hole. Oh and icing on the cake, close to breaking point, I tried going back to my previous gen3 500GB M.2 drive with my old windows 11 account and it now stops me at the pin login screen saying I need to change my pin, it then tries to connect to the internet to do this but cant. Again it’s a wired connection and that drive has all its internet drivers up to date so it makes no sense. So I can’t even get past the pin login screen on my old drive either!

0 Replies