windows 11 thunderbolt 4 bug

Visitor

Hi, I got a new Dell XPS 15 9520 (12th gen i9) few months ago. When I connect a Thunderbolt audio Interface, nothing happens, like if the port was dead. I've look in device manager and I cannot find any Thunderbolt Controller. No Thunderbolt services was running and even Intel Driver and Support Assistant cannot find any Thunderbolt controller on my laptop. I've opened a ticket with Dell. They change the motherboard, change the controller, nothing is working. After some search about this issue, I find other people with similar issue with other brand laptop (hp, Asus, Lenovo) but always with a 12th gen Intel. I made a clean install with windows 10 and the Thunderbolt controller show up immediately (model 463e). Everything works fine on windows 10. Finally, I start an update to windows 11, build 22623.730 and my thunderbolt is gone again. On intel and Dell website, both report that there's no additional driver for thunderbolt with a 12th gen CPU and windows 11.  Someone else are aware of this issue?

6 Replies
Same here, seems that in Windows 11 the ports works as USB4 only, it's so weird :\ plis if you find a solution let us know.
I have an Windows11 Alienware laptop (12 gen i7) and starting just a few days ago, my egpu setup is no longer working. It blue screens when I try to plug in my Razor egpu and I also don't see the Thunderbolt Controller in my Device manager any longer. This worked fine just a few weeks ago!
Same here. Lenovo slim 7i pro x
i7-12700H, there's no thunderbolt controller on Windows 11

@Projectik - I am experiencing the same issue on latest Windows 11.

 

Thinkpad Yoga X1 Gen 7

Windows 11 Pro 64-bit

12th Gen Core i7-1280P

32GB RAM

 

I have had the motherboard replaced, tried a handful of drivers (Windows 10 drivers from Lenovo, Intel NUC driver package, www.catalog.update.microsoft.com) all of varying version numbers and via various methods (running the exe package, manual install via device manager). I just finished performing a factory restore from a USB Lenovo sent me, and am checking Device Manager before every update. Haven't been able to get the Thunderbolt controller to show up in Device Manager.

Okay, so my issue turned out to be a bit different after all... It appeared to be due to driver miss-match. Here is the solution for my specific problem--https://mysupport.razer.com/app/answers/detail/a_id/5870/kw/Core%20X%20Chroma
By showing hidden devices under Device Manager when disconnected from the internet, I was able to find the hidden device and remove the driver causing the issue.  

...same here on HP Studio G9