Windows 11 setting app not opening just shows gear icon

Copper Contributor

So as the title ltge title says my settings will randomly not open window comes up with just the gear icon at the center.  It happens randomly and works again on restart or sign off.  I've tried a in place install I've used sfc dsim powershell etc every fix I could find and it still occurs.  Been this way since 2 cumulative updates back.  Seems everything I get a new cumulative the error occurs. Has anyone else encountered this?

7 Replies
Hello,

See if this fix helps you anyway:

https://www.kapilarya.com/fix-settings-app-wont-open-in-windows-11

Let us know if this helps!

Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.

@Kapil Arya 

 

I've done this the problem just returns I'm not sure what's causing it.  Seems to be after cumulative updates something goes wrong with my system.  But sfc and dsim always show nothing being wrong so I'm assuming a 3rd party or something outside windows is at fault just not sure what since it's fine after a in place upgrade.  

@Kapil Arya  still can't determine the app.  I've tried a clean install and the issue remains.  I have narrowed it to its not that it won't open the last instance of it continues to show in task manager but I'm unable to end it.  So I'm assuming it's a bug with the update and my system.  Hopefully it works itself out with more updates to apps and windows.  Restart or sign off fixes it temporarily.  

I've narrowed jt down to my killer 1675i wireless card driver and windows 11 system broker. Something seems to be conflicting with them. I'm going to try a non 6ghz card in a week when it arrives to see if this solves the issue. I found similar posts of conflicts with system broker and other wifi 6e cards. So it's most likely a windows 11 or intel problem

faulty wireless card was to blame removed and replaced problem gone.  Thank you for your suggestions.  @Kapil Arya 

Glad it is resolved, thanks for update!