Windows 11 Multiple Windows Explorer Processes Bug(??)

New Contributor

Hey Y'all,

 

I have 2 instances of Windows Explorer opened in the task manager at random times. It happens when i restart my computer, use it for some time and after a while i notice the fans ramp up, i go to the task manager to find two processes of windows explorer, one is normal in my opinion which has 200-500MB RAM usage while the one is the problem, it consumes 2000MB of RAM (I have only 8 gigs ram so I am always anxious about that). I kill the process with the high ram usage and the computer runs normally. It is also worth mentioning that when i kill the process; the explorer and all the windows and task bar does not close or crash. The computer cools down and everything goes back to normal. The explorer.exe file is also normal. I was hoping that it might get fixed in the update but its still here.

 

Can you help me with a permanent solution? I already did the following to no avail;

 

  1. System File Checker
  2. ChkDsk
  3. Malware scan
  4. Checking installed Add-ons
  5. Running Disk Cleanup

A screen shot of the issue is also added below.

5 Replies
Are you experiencing the same behavior in the Safe Mode?
Have you tried download and install all updates?
Try open start and search for feedback and open the Feedback Hub app and report this issue.

@Reza_Ameri Hey Reza!


Thank you for much for the suggestion but the issue still remains the same. I am fully updated and for some reason I can not find the feedback hub. It used to be in windows 10 but now when i search for it, it gives me "Feedback and Diagnostics" which has no option to report a bug, apparently there is a option to give feedback though, when you search something on the start menu; on the right top side there is an option to give feedback, just a little tiny button. I did that and lets see what happens...

 

I have also attached the screen shot of the issue so you can see for your self.

In the Windows 11, you may open start and click on "All apps" and from the list find the Feedback Hub app.
So, you are facing the same issue in the Safe Mode too?

@Reza_AmeriYeah still could not find the feedback section :sad: there was a get help section which has no option of feedback and directs it to support.

 

I am sorry i could not try safe mode before, this time i used it for 30 minutes and the issue still persists. Even after closing all the windows the process remains in task manager with high memory use.

 

Screen shots are attached.

 

same issue.jpgsame issue 2.jpg

Have you tried DISM command too?
You may run the following commands:

DISM /Online /Cleanup-Image /ScanHealth
DISM /Online /Cleanup-Image /CheckHealth
DISM /Online /Cleanup-Image /RestoreHealth