Windows 11 Dev 22449 windows surface pro X arm Error encountered

Copper Contributor

Hello all,


I am using Microsoft surface pro X arm based and right now after update to Dev 22449.

I can't run windows update anymore, it's just keep saying 'error encountered'

I'm stuck at build 22449:(

Screenshot 2021-09-25 220336.jpgwindows11, surfaceprox


Can anyone help to resolve this?


Thanks a bunch

10 Replies
Error appears to be.

1) You missed recent change in the development cycle and Microsoft is no longer using that version
2) software distribution folder (hidden Under) C:\Windows (has become corrupted over time)
3) bad update for the Windows update services

Check and down load the newest version of development cycle for Windows 11.
Go to your favorite web browser and search for the articles on softwaredistribution folder fix.
Wait and recheck to see if Microsoft has fixed the issue.
Take a look at:
The article for Windows 11 is not available yet, so you may follow the one for Windows 10 instead.
Thank you for the suggestion, has tried the troubleshoot here but it didnt work for windows 11
Hello Darkemance,

Have tried with 'softwaredistribution folder' to fix the issue but it's still make the windows update error encountered.
Which part didn't work?
Please share it so we could guide you.
Just followed every tips from the link unless the perform a clean installation for windows, since i dont want to reset my windows to factory reset Reza.
So you followed all steps and it didn't worked, correct?
In this case, open start and search for feedback and open Feedback Hub app and report this issue.
Try change the Channel from Dev to Beta and see if this will solve the issue.

@Reza_Ameri yes it didnt work, just sent this report to feedback hub.

Hope someone can help me to figure it out.


Thanks for the suggestion

Hello, if you wish you can try to do a in-place upgrade with this ISO from here, make sure to be signed in with an insider account.

If you do a reset on Windows 10, it will prompt you to upgrade to Windows 11 if you have ea inteiret on and have the KB installed

Hello Shawn, i tried to use hyper v and upgrade to build 22454 in virtual machine connection,

(photos as attached)

Next i can't figure out how to install in-place upgrade to my real machine,
can you help to guide the next step i can do?
Really appreciate.


Thank you