Windows 11 Amazon Appstore does not get past signin

New Contributor

I've been trying to get Amazon Appstore working but can't get past the signin.

 

When I click Signin it spins for a while then briefly pops up a message which I've just managed to capture before it returns to the signin.

 

The message is:

Web Page Not Available

The web page at https://www.amazon.co.uk/ap/signin? etc (more stuff)

could not be loaded because:

net=ERR_NAME_NOT_RESOLVED

 

I've just recently had the update that allows the appstore to be installed and am a UK user.

 

Any ideas?

4 Replies

@splashscuba 

 

I have exactly the same problem. I am in the UK and have been upgraded automatically to Windows 11 22H2. I am trying to access the Amazon Appstore like you but get the spinning wheel. All I saw was web page not found so you have got a bit further than me. That message implies it is not resolving the web page and suggests setting 8.8.8.8 as a static IP. I haven't tried that but I use static IP for my wi fi and set dns to the router address 192.168.0.1. I am running PIA VPN and have tried pausing it to no effect and I also use eset antivirus so interested to compare notes !

No VPN, DHCP for me. Couldn't be more vanilla. I've given in.

I am surprised more UK windows 11 people not experiencing the issue after the 22H2 upgrade - anyone got the Amazon appstore working correctly?

 

I brought a new large screen laptop with W11 to consolidate the need for an android tablet so interested to see if apps genuinely can work with Windows

So appstore updated and, just like that, I'm in (signed in)