Testing WINRm error

Iron Contributor

When I run Test-WSMan -Computername "computername" I get the following error message


Test-WSMan : <f:WSManFault xmlns:f="http://schemas.microsoft.com/wbem/wsman/1/wsmanfault" Code="2150859046" Machine="Win11.abcd.local"><f:Message>WinRM cannot
complete the operation. Verify that the specified computer name is valid, that the computer is accessible over the network, and that a firewall exception for the
WinRM service is enabled and allows access from this computer. By default, the WinRM firewall exception for public profiles limits access to remote computers within
the same local subnet. </f:Message></f:WSManFault>
At line:1 char:1
+ Test-WSMan -ComputerName WSMWin-8fNBldft
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (WSMWin-8fNBldft:String) [Test-WSMan], InvalidOperationException
+ FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.TestWSManCommand


So, I thought that changing it to Domain wide might help but not sure how to enable it or if that is what needs to be done?


I tried to run Winrm quickconfig and I get the following error 


Message=WinRM firewall exception will not work since one of the network conenction type no this machine is set to Public. Change the network connection type to either Domain or Private and try again.


Error Number: -2144108183 0x80338169


1 Reply
Hello, is this error still occurring?