Questions on SSD problem on Windows 11

Copper Contributor

I've noticed that my SSD seems to be slow or unresponsive at times, with delays when booting up or loading applications. This happens intermittently, and it's not consistent across all tasks, but it's been happening frequently enough that it's become annoying.

 

I've tried to troubleshoot the issue by checking for disk errors, running disk cleanup, and ensuring that my system is up-to-date with the latest Windows patches. I'm not sure what could be causing it. I'm hoping someone might have some insight or suggestions on how to resolve this problem.

3 Replies
Over time, your SSD's free space can become fragmented, leading to slower performance. You can use the built-in Windows tool, "Disk Defragmenter" (or "Optimize" in Windows 10), to defragment your SSD.
hello: pls wath is this ???? Vous avez demandé trop de codes aujourd’hui. Réessayez demain.
SSD latency issues can stem from various sources.
For information, there are different qualities of SSDs related to memory (low, medium, or high quality - TLC, MLC, SLC, etc.) that will support more or less write cycles. Age and usage are then factors to consider.
Initially, I would tend to explore a few avenues: the first on the side of the SSD firmware, and possibly the disk controller drivers.
To check if the SSD firmware is up to date, I recommend using only the utilities from the SSD manufacturer. For example, for a Samsung, it would be Samsung Magician or for a Kingston, the Kingston SSD Manager. These tools will also offer SSD diagnostic utilities and check its general state.
Another avenue could be to check the basic settings in the BIOS, for the disk controller. This is a more complex operation, difficult to guide here, as it will depend on the type of computer (desktop or laptop), the motherboard brand, etc.
Another possible avenue: disable the indexing of the content of the files on the drive, which tends to solicit the SSD. A right-click on the hard drive then Properties allows you to access this setting. Just uncheck "Allow indexing of the content of the files on this drive (...)"
I don't know if these few indications will be able to help you, but I sincerely hope so.
Kind regards.