Program window not closing

Copper Contributor

I updated to Windows 11 about a week ago.  On shutting down several programs (Firefox, Thunderbird and Calibre so far) the programs themselves close (icons disappear from Taskbar, processes disappear from Task Manager, etc) but the program window remains on-screen, unresponsive, can't be closed or minimised and it overlies any other window which opens.  The only way out is to log out and back in again.  Any suggestions?

12 Replies

Hi @BillM10UK , 


Please follow the below link, I hope this article could helpful for you.

Thanks, but the problem is not that the program is unresponsive/frozen and needs to be killed. The program/processes/tasks shut down quite happily, it's just the window contents which remain fixed and unmovable. I've found a workaround which is to minimise the window then right click the taskbar icon and select 'Close all Windows' but I'd rather get it fixed properly.

Hi @BillM10UK 


Please run Windows Update, one of my colleague was having the same issue, but the issue has been successfully fixed once he run the windows update manually.

This issue is *not* fixed. December 2021 here, more than two months after this post, and the issue remains unresolved even via Windows Updates, plus a whole slew of other Explorer-related issues, such as Explorer windows eventually becoming absent of any information, requiring a hard explorer termination and restart.


The original problem has settled (mostly).  If the program windows remain on screen then a two finger tap on the finger-pad closes them.  I'm still having trouble with other windows.  Installation dialog boxes fail to close and get in the way of other things on screen and various File Manager progress boxes remain in place near permanently.

@BillM10UK I too am having this issue (specifically with Outlook, Explorer, Teams, Zoom, all java UIs, and some others).  I've applied all the updates available and nothing seems to help my Lenovo P52s (laptop/tablet).  I am wondering what you are referring to when you say "two-finger tap on the finger pad".  How does that translate to a mouse?  Any idea?

@wjgray Also having the same issue on a lenovo thinkpad. I'm also unable to maximize the majority of windows. The program maximizes, however the dimensions of the application does not change. The border around the program just encompasses the entire screen, but does nothing. I tested this with a brand new C++ application I tested in VS and it still had the same issues.


I wish I could backroll back to windows 10, honestly.


is there someone who fixed that issue ? So I had the same problem, I fixed it like this, 

right click on desktop , there is  display settings, there you will see resolution of desktop and scale, if the scale more than 100%(125% or 150%) please make it 100% . Its helps me , i hope it will help you also, still don`t know why its have to be like that, and still updates not helping, only changing the scale helping. 

If it will help you please replay, I will be glad to know that its helps. 

And if its works for another`s   , hello Microsoft, what about vacant?))))

@Arsen0211 I bought a new HP laptop with Microsoft 11 installed. I was trying the different solutions as I went down the list and the one that worked for me was logging out and logging back in again. I did it just now so I don't if this will last. If it doesn't I will post again. 

Had similar problem after upgrade from Windows 10. Issue was performance setting inherited from Windows 10:
'System Properties/Advanced/Performance/Visual Effects' had "Custom" settings. Changed to "Adjust for best performance" and problem corrected.
It's 2023.
Two and a half trillion dollar company still didn't find a programmer who would know how to fix this :D hahaha what a garbage of OS :)

@DJBakerThis is a bit old but.. This worked. Thank you so much!