Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Problem with microphone access on certain applications

Copper Contributor

Hello, I've been having a problem where my laptop's internal microphone does not work on certain applications. I have tried everything I could find on troubleshooting guides with no success. Programs are able to detect my microphone and connect to it but does not receive any inputs from the mic when testing. However, I am able to use the microphone on google chrome for some reason. With discord, the microphone works on the web browser version of discord while not working on the downloaded program itself with identical settings

I have tried reinstalling the programs that are having this problem, reinstalling my microphone driver, checked access permissions, turned the microphone off and on again from sound settings, and tried windows troubleshooting. I have a feeling that the issue is permissions related since the mic does work for chrome but I have double checked that permissions are granted to applications.

Any help would be appreciated.

 

This is on the web browser version of discord:

Screenshot 2023-08-10 124815.png

On the discord application itself (downloaded program):

Screenshot 2023-08-10 124851.png

 

Microphone access permissions:

Screenshot 2023-08-10 125214.pngScreenshot 2023-08-10 125200.png

 

Microphone device is turned on (the green bar moves when I try talking into the mic):

Screenshot 2023-08-10 125601.png

3 Replies

It sounds like you've already taken several troubleshooting steps, but microphone issues can sometimes be quite tricky to resolve. Since the microphone works in some applications (like Google Chrome) but not in others (like Discord's downloaded program), it might indeed be related to application-specific settings or permissions. Here are a few additional steps you can try to further diagnose and potentially fix the issue:

  1. Check Application Settings:

    • For applications where the microphone isn't working, go through their settings to ensure that the correct microphone is selected. Sometimes, applications might default to a different microphone or audio input device.
  2. Run as Administrator:

    • Try running the applications that are having microphone issues as an administrator. Right-click on the application's shortcut and select "Run as administrator." This might help ensure that the application has the necessary permissions.
  3. Check App Permissions:

    • For Windows 10, go to Settings > Privacy > Microphone. Make sure that the toggle switch for "Allow apps to access your microphone" is turned on. Also, check the list of apps that have access to the microphone and ensure that the apps you're having trouble with are listed and have access.
  4. Disable Exclusive Mode:

    • Right-click on the speaker icon in the system tray and select "Open Sound settings." Under the "Input" section, click on "Device properties" for your microphone. In the Microphone Properties window, go to the "Advanced" tab and uncheck the box that says "Allow applications to take exclusive control of this device." Click OK to save changes.
  5. Check Audio Drivers Again:

    • Make sure you have the latest audio drivers installed for your laptop. You mentioned reinstalling the microphone driver, but also check for any general audio driver updates.
  6. Create a New User Profile:

    • Sometimes, issues can be related to a corrupted user profile. You can try creating a new user profile on your Windows system and see if the microphone works properly there. If it does, the issue might be specific to your user profile.
  7. Contact Application Support:

    • If the issue persists, consider reaching out to the support teams of the specific applications (e.g., Discord) that are having problems. They might have additional troubleshooting steps or insights into the issue.
  8. Windows Updates:

    • Make sure your Windows operating system is up to date. Sometimes, certain bugs or compatibility issues can be resolved through Windows updates.

Remember that diagnosing and resolving software and hardware issues can be complex, and it might take some trial and error. If the problem persists, it might be a good idea to consult with a professional technician or the support teams of the applications involved for further assistance.

Access my all account data

@mih8a9ssa 

 

Actually the app I am having issue with is not listed in the privacy section under " autorhized app "..

 

How can I manually add it ?

 

Thanks in advance.