I cant install Windows 11

Copper Contributor

I had Windows 11 OS running on my desktop for several months but the other day,my SSD died on me that had the OS system on it, so i replaced it and tried to install Windows 11 back on.

Windows 11 wouldn't install as it said my PC didnt meet the requirements,even though it was installed in the first place.

So unable to install Windows 11,i installed Windows 10 just to get my PC back on.

Windows 10 installed fine,then i tried to find out why my pc didnt mee the requirements. 

I downloaded PC health check i think it was called and there were 2 errors showing that needed to be rectified. 

One was secure boot but my system said it wasn't supported,even though i did have it on days ago and i think the other was called TPM 2,not a pc but can check that one again. 

Anyway i tried to find out how to fix these 2 errors.

I tried to fix the secure boot by changing the drive from MBR to GPT and i used the comand prompt 

mbr2gpt /validate / disk:0 /allowFullOS

mbr2gpt /covert / disk:0 /allowFullOS

Anyway it didnt work.

My bios is already set to UEFI mode.

So can someone help me to fix this issue as to why i can't put Windows 11 back on?

2 Replies
Kindly confirm, if Secure boot is on, and TPM is enabled under BIOS settings.
My system information said secure boot was unsupported
Anyway i flashed to the latest Bios and now it says off,so that's better than showing unsupported.
So how do i enable secure boot?
And for TPM to show,i had to enable Intel Platform Trust Technology (PTT).
Then when i clicked on Trusted Computing,it showed TPM 2.0
But then my pc suffered from BSOD and no matter even when i went back into the Bios and disabled what i enabled the pc still wouldn't boot at all and it couldn't be fixed.
The error from BSOD was,
Anyway i had to stick Windows 10 back on just to get my PC back on
So its a fresh install showing the latest bios.
So how can i safely enable
Secure Boot
My motherboard is Gigabyte X299 UD4 PRO.