How to resolve BTHUSB Event ID 7 Issue

Copper Contributor

After installing the latest updates of Windows 11, my laptop's BT is disappearing 2-3 secs and reappearing. (it is extremally annoying when you are using a Bluetooth mouse) When I checked the event viewer following event was there. Hope someone can help me out.


BT Driver and BIOS are up to date.


Log Name: System
Source: BTHUSB
Date: 11/18/2021 2:44:47 PM
Event ID: 7
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
A hardware error occurred. The event contains the vendor-specific error code.
Event Xml:
<Provider Name="BTHUSB" />
<EventID Qualifiers="32773">7</EventID>
<TimeCreated SystemTime="2021-11-18T09:14:47.7326466Z" />
<Correlation />
<Execution ProcessID="4" ThreadID="11580" />
<Security />

11 Replies
Hi @udaraso - I have exactly the same issue - it is really annoying. Have you found a way to solve it? I have done all sorts of updates (Windows and Dell Inspiron) but no luck. I did have this issue a long time ago with Windows 10 but it got sorted by an update, so I am pretty sure it is a driver issue with Windows 11.
Hi @Robin999
The solution was not to connect the Bluetooth mouse (Logitech M590) directly to the laptop. I connected the mouse using the Logitech USB Receiver that came with the mouse and the problem was resolved. Unfortunately, due to this issue, one USB port is utilized for the wireless mouse. 

@udaraso thanks - unfortunately that doesn't help with my situation, where I use the same Bluetooth Keyboard and Mouse with two computers (switching from the USB receiver on the desktop to the Bluetooth on the Laptop). It worked fine with Windows 10 but not Windows 11. I have ended up having to use a separate mouse for the laptop and having to use the laptop's built-in keyboard, which is not ideal for my setup (it is docked on a stand). Should be possible to just update the driver to stop this happening (or I may try to roll back the Intel Wireless Bluetooth driver to a version that worked such as v21.110.0.3).

@Robin999 I also use my wireless mouse in two laptops (Lenovo & Dell). Both running in Win 11. But, I'm facing the issue only in the Dell Laptop. So, I connected the mouse to Dell laptop from the receiver and Lenovo directly. Hope you are using a Logitech mouse which having FLOW feature.
@udaraso actually I use a Dell Mouse (WM527) and Keyboard, but the FLOW feature you mention sounds very interesting - does it work as well as Logitech say? Can you really copy and paste across devices and not have to click a switch to change device?
best response confirmed by udaraso (Copper Contributor)

@udaraso I think I have fixed the issue! After checking if Dell had any suggested updates, and installing the Intel Wireless Bluetooth Driver version, it did not fix the issue. However, I went directly to Intel's site and found that the latest driver they had was version (15th Nov 2021) which has been designed to support Windows 11. After installing this driver, no more problems! Here is the link - I hope it works for you too! 

Good to hear that your BT issue is sorted.

Regarding FLOW. Yes, it does works across the devices and you can copy and paste if the both devices in the same network as well.


Thanks buddy for the tip. It worked great for me too!! :)

... a nice Christmas present @Nuthellen! - glad it worked! :)

@Robin999 THANK YOU!!!!  I was fighting with this issue with my desktop about six weeks ago and finally gave up and bought a Logitech mouse with a dongle.  Then the same problem developed with the same model of mouse (a Microsoft bluetooth mouse, ironically enough) on my Dell laptop when I ran a Windows update a few days ago.  I'd tried reinstalling the driver (from Dell's web site), and a Windows reinstall to no avail.


Intel's version is newer, and wasn't available when I was troubleshooting the desktop, but it seems to have done the trick on my laptop.  I was thinking I was going to need to replace this mouse as well, as I'm only willing/able to dedicate a certain amount of time to troubleshooting these issues.


Thanks again.



So pleased to hear that this resolved your issue @Ted_MacDonald - it took me a long time working on it (after trying many 'fixes' and even looking at tweaking registry files) and I am glad if it saves others from doing the same. I have also contacted Dell and told them that they should update their advice and update program with this driver.