GPMC throws a scripting error when running the latest Windows 11 22H2

Copper Contributor

When running the Group Policy Managment Console in Windows 11 22H2, editing a group policy, produces the following error:


Can be reproduced, by selecting something with sub-menus, like Local Users and Groups. Screenshot below as an example:


It worked, before the latest 22H2 update was rolled out. I am a server admin and use this functionality almost daily. Please let me know what can be done, to resolve this issue. If there is no workaround, please report to the correct group, so the issue can be addressed.


I have tried two different machines, running the same version of the OS. It produces the same result.


Let me know if you need any additional information to troubleshoot this issue and when we can expect a fix.




6 Replies

Hi @Jason360 

It seems that in this space you will get a faster answer, start a discussion there:

Microsoft Intune and Configuration Manager - Microsoft Community Hub


This looks to be a link to Configuration Manager hub. This is strictly a problem with Windows 11 and GPMC. There doesn't seem to be anything specifically related, but it did not present as a problem until I upgraded to 22H2. It has to be related to a change made, as part of that update. I appreciate your suggestion, but I am not sure they would be able to help me much. I was hoping someone from the MS Windows 11 development team would see this post and provide some type of feedback or point me in a direction. There is little on the web regarding this bug and it needs to get to someone who can address it. Thanks again for your response and I welcome any other suggestions.


Send feedback to Microsoft with the Feedback Hub app - Microsoft Support

Please this way you can pass the diagnostic data so that the Microsoft team will fix it, your post is already visible and valid.

@Jason360 , did you get a solution from Microsoft?
We have the same problem!

I opened a case through the microsoft service hub. They were able to reproduce the problem.
As soon as I have new information, I'll post it here

I´ve got the information from Microsoft Support, that this bug will be fixed within the upcoming march CU! We will see ;)