Dsound.dll Eroor

Copper Contributor

Im on winbdows 11 Pro N insider Preview, im having an issue where I was trying to download the game Valorant, I was getting an errror : The program cant start, because dsound.dll is missing. So to try and fix that I tried downloading DirectX and this didnt solve my issue, ive tried possibly everything and cant get it to work. Also when I open Run and type DxDiag I get a error : DxDiag Error getting extra sound info 

11 Replies


Hello! You've posted your question in the Tech Community Discussion space, which is intended for discussion around the Tech Community website itself, not product questions. I'm moving your question to the Windows 11 space - please post Windows 11 questions here in the future. 

Hi, i have the same problem, does anyone can help ?

@Kripy same here, windows 11 is full of bugs, even in the non-insider preview builds


my freinds are NOT facing this issue at all


Same Issue here, and same TS done but still encounter the same issue, after installing Valorant. any solutions to fix this?

Exactly the same issue here. Just that I'm on windows 11 Home N. I'm on a HP OMEN (amd ryzen 9 5900hx) model 15-en1000nq


Any fixes? 

You need to switch from Windows N to regular Windows. I had this issue as well, tried re-installing multiple times. I had to switch to regular Windows for Valorant to open again, it must have something to do with the media elements that the N edition removes.
This is easy to fix. Download the dll file and place in where the game files are. Or the location needed.

here is link. Get version you need. https://www.dll-files.com/dsound.dll.html
Windows 11 N users do have this DLL file, however it doesn't fix the issue. I spent a day or two trying to fix it, and verified that I had all of the necessary DirectX files, including dsound.dll, which I placed it in both System32 and the game root.

@joshcantcode bonjour , j'ai réussi a corriger cette erreur , il faut se rendre dans les paramètres windows> applications > fonctionnalités facultatives > afficher les fonctionnalité facultatives > et télécharger media features pack puis redémarrer le pc. ceci a corrigé tous les problèmes que je rencontrais.


For me it also worked when I reinstalled from N to regular Windows. Thanks for the tip. @joshcantcode 



The only solutions available are:


1. Go into the BIOS setup and disable CMS support. I spent a whole week looking for a fix to that issue, tried 12 solutions and this one did the trick (didn't really find it anywhere, just tried it guessing that maybe vanguard was blocking something).


2. Downgrade you Windows 11 [N] to a version without the [N].