Windows Update - Error Encountered

Copper Contributor

Dear All,


How to fix this below issue?


Error 1.png

Note: Internet is working fine, but i'm using Proxy and proxy has been setup.




4 Replies
best response confirmed by Muhamad Fahrurrozi (Copper Contributor)

failing to connect to a update server can be caused by a network driver, two many tcp/ip connections or a router problem you can check your current connections by starting cmd.exe or powershell as an admin then run netstat.exe / will show the current stat of all of the network connections and the program that is using them. These are a limited resource. when one connection is closed there is a 300 second wait before it can be the program and see if something stupid is using all of your connections. if so, you can shutdown the program before doing your updated. streaming programs you don't use can tie up connections. programs streaming to a loopback driver can tie up connections.
generally, when you run out of connections the transport will put a event in the event log and will start to throttle the connections to slow it down.there are some cases where you have to delete the software distribution cache before windows update starts working again. there are some hacking programs that block access to the windows update and might fake a response. they do this so the activation appears to work. I think the block works for up to 180 days before you have real problems. updates tend to wipe out the hack and the true state of the activation is revealed.
generally these programs are run once a day in the task scheduler generally it would be best to not use raid, in your case you would install windows on the first drive using sata AHCI then install the second drive as a subdirectory on your c: drive @Muhamad Fahrurrozi 

@Muhamad FahrurroziI had similar problem recently and tried everything available on the web. Tried renaming folder, restarting services to changing user accounts and nothing helped. However in my case for some reason my LAN connection was the main cause of the error. I switched from LAN to WIFI and windows update and store both started working fine.

@Muhamad Fahrurrozi 


I give you an address maybe help you: 

go to computer management which is:

(right-click on start  >>> computer management; or; ctrl+R and write services.msc >>> hit enter)

then open '>' belong to the Services and Application and then click on Services that has gear icon.

wait till items in right panel appear. scroll down to find windows update. look if it's enable or not. if not right-click on it go to properties and change "Startup type" to Automatic. At bellow click on start wait to fill it and then click on OK. Now I think you can run your update.


Same problem as @Muhamad Fahrurrozi

Trying to build a gold image of win 10 1909 using an mdt build and capture task sequence.


successfully created a fully patched wim with multiple applications on it and successfully deployed it via SCCCM to a virtual machine in Hyper v

used iso 1909.3


The newly imaged workstation seems fully functional, and  is able to connect to our on prem sccm wsus point.

It is not able to connect with the Microsoft wsus point, giving a x80240437 error. on other attempts it gives error  800b0109


tried numerous things to try and resolve.

Verfied that adjacent VM on same computer functions as expected. 

Space is not an issue.

Tried mid task sequence prior to installing applications - same result

Tried to restore health using DISM

Renamed software distribution folders and catroot2

ran sfc/scannow

Tried starting over using iso 1909.1

Tried looking at netstat for tcp connections


am at a loss for what to try next


any help would be appreciated