SOLVED

Windows Subsystem for Linux Update - 5.10.93.2 failed to update

New Contributor

Hello,
The non-optional update of "Windows Subsystem for Linux Update - 5.10.93.2" fails: Installation failed on 03/25/2022 - 0x80070661
Any help would be welcome
Thanks in advance.

 

32 Replies

@JdTissot Same issue here... Did you restarted your PC before installing this update?

Same here... gave numerous attempts but keeps failing. Even restart doesn't help installing it
Same error here.
I have restarted my pc and it doesn't fix it.
Same issue.
Windows Subsystem for Linux Update - 5.10.93.2
Install error - 0x80070661

Cleared WU cache, restarted, the usual steps when an update is failing
Same issue here. Tried restarting and stopping the WSL and Docker, but no luck.
Failing for me as well.

Same issue on me...

I found this: https://github.com/microsoft/WSL/issues/8186

it says that windows update tries to install arm64 package for x64 system and that gives error.

I am trying the solution at here, to manually downloading update...

...

Yeap, manual download working. Install update cab for your system version, unpack and download update. Result: Update done and no warning for that update again.

Well, if everyone is having the same problem, there is clearly a problem with update. But will Microsoft acknowledge their problem and fix it?

@JdTissot 

 

I would like to propose the following solution: 

 

Click on this link: 

https://www.catalog.update.microsoft.com/Search.aspx?q=wsl 

 

Choose the correct version and then click on download. Choose the correct processor type. Download the CAB-file and extract it to get the corresponding MSI-file. Then install the MSI-file and it should be working. 

 

You may also use the WSL --update command to check for updates afterwards. 

 

It worked on my laptop.

 

Kind regards,

Kelley

@JdTissot 

 

Same here as well 

 

0x80070661 - Linux 

It solved the issue for me!!

@Kelley1995 Your fix to manually download and update worked

I am also facing this issue for some time now.

@Kelley1995 Well, that process seems to have changed the error, although it's not obvious that it's going to install the rest of the updates. We'll see. Thank you!

 

On a side note, when downloading the file Chrome gave me an error about not being able to download securely. I wonder if it's an expired cert or something. (I'm not interested enough right now to look)

Worked for me :thumbs_up: Thank you!