Windows Store won't get new apps since 1803 update

Copper Contributor

This started happening with me on the 1803 update, Something is following my account around that is disabling downloading anything new from the store. I don't get an error though. Instead,. when I click the Get button, the entire store refreshes and brings me right back to the same screen with the Get button still enabled. I never actually download anything.


I've tried the following over the last week to try to fix the issue:

1. Totally clean install, new partitions the whole nine yards. And shortly after linking my Microsoft account, same result.
2. Ran all the frigging troubleshooters and the only one that came up with anything was complaining about not being to connect to the Sync service,. The troubleshooters did not provide any instructions on what to do about it. Everything seems to be syncing fine. Cortana, my contacts, switching off to the pc from the phone with edge, sending a pic from my phone to my PC, all working,..
3. Created a second account on my machine to test with. I logged in as the new user, went to Microsoft Store app, logged in with my Microsoft Account and was able to download anything I wanted to, owned or not. So I thought maybe it was a profile being corrupted and decided to move everything over to this new account since it appeared to be working. Another huge pain in my ass that was. 2 hours later I have everything setup as it should be.
4. Went to the app store a couple of hours later and I (again) cannot download anything with the exception of the apps that are specifically from Microsoft or that I have downloaded in the past (apps in my Library).

5. Click on my account in the store and selected 'Sign out'. Went back to app that I was attempting to install and click on the 'Get' button. Window popped up asking me to select a Microsoft account to use. I selected my linked one, the one I had just signed out of the store, and once I verified my PIN, the app started downloading.

6. A few installs and a couple of hours later, I go into the store app and randomly picked an app, one that would have to be purchased. I clicked the purchase button and the window goes black then reloads the same app details page with the purchase button. Clicking on the purchase button just refreshes the current page from that point on and I no longer get any new apps.

7. For the last week, if there is an app or an update I want to get from the Store, I have to sign out of the store first, then sign back in when I go to get the app. The store works fine for a little bit but after awhile it stops allowing me to get anything and instead just refreshes the page. No error, nothing in the event logs.



Details of my install:

Downloaded ISO from official retail channel. Clean install of 1803 Professional.

Activated with a Professional for Workstations key from my MSDN subscription. Activation was successful.

First account I registered I did as a Microsoft Account, not a local. From the get-go, I had problems with the store. Cleared it's cache, reinstalled/registered it through Powershell, ran the troubleshooters, blah, blah, blah. Things didn't start looking up until I tried using a fresh local account. Which worked for awhile but stopped. It would seem that something is being synced to my account that is causing the problem but I cannot tell what. 


Anyone else experiencing this?




1 Reply
best response confirmed by Perry Blanchard (Copper Contributor)

An update to the Store app ended up fixing the issue.

1 best response

Accepted Solutions
best response confirmed by Perry Blanchard (Copper Contributor)

An update to the Store app ended up fixing the issue.

View solution in original post