Windows losing HDMI connection periodically when in Dual Monitor mode

%3CLINGO-SUB%20id%3D%22lingo-sub-2116675%22%20slang%3D%22en-US%22%3EWindows%20losing%20HDMI%20connection%20periodically%20when%20in%20Dual%20Monitor%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2116675%22%20slang%3D%22en-US%22%3E%3CP%3EW10%20in%20dual%20monitor%20mode%20(laptop%20-%20Primary%20Monitor%20%2B%20external%20monitor%20-%20Monitor%202).%20Periodically%2C%20the%20laptop%20screen%20will%20go%20black%2C%20the%20Windows%20Display%20reverts%20to%20%22show%20only%20on%20monitor%202%22%2C%20and%20although%20I%20can%20continue%20working%20on%20monitor%202%2C%20the%20laptop%20just%20%22seems%22%20dead.%20It%20is%20not%20dead%20at%20all%20however%2C%20since%20if%20you%20run%20the%20DETECT%20in%20the%20display%20option%2C%20it%20immediately%20detects%20the%20laptop%20again%2C%20although%20strangely%20the%20browser%20session%20I%20had%20open%20now%20reverts%20to%20the%20laptop%20has%20now%20moved%20over%20to%20the%20primary%20monitor.%3C%2FP%3E%3CP%3EAll%20drivers%20are%20up%20to%20date%20and%20no%20%22bangs%22%2C%20and%20I%20have%20tried%20with%20both%20new%20HDMI%20cable%20and%20different%20monitor.%3C%2FP%3E%3CP%3ENothing%20corresponding%20in%20the%20event%20logs.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20assistance%20in%20troubleshooting%20more%20than%20welcome.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2116877%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20losing%20HDMI%20connection%20periodically%20when%20in%20Dual%20Monitor%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2116877%22%20slang%3D%22en-US%22%3EThanks%2C%3CBR%20%2F%3EI'd%20suggest%20updating%20your%20OS%20to%20the%20latest%20version%20too%2C%3CBR%20%2F%3Elatest%20version%20is%2020H2%2C%20it%20keeps%20getting%20better%20after%20each%20update%2C%3CBR%20%2F%3Eyou%20tried%20a%20new%20cable%20but%20made%20no%20difference%2C%20so%20why%20not%20trying%20a%20new%20OS%20version%20%3A)%3C%2Fimg%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2116862%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20losing%20HDMI%20connection%20periodically%20when%20in%20Dual%20Monitor%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2116862%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1909%2018363.1316%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EConfirm%20this%20does%20NOT%20happen%20when%20using%20just%20the%20laptop%20and%20no%20second%20monitor.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEven%20if%20I%20had%20some%20log%20files%20to%20check%20or%20heightened%20event%20logging%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2116807%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20losing%20HDMI%20connection%20periodically%20when%20in%20Dual%20Monitor%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2116807%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Ejust%20want%20to%20check%2C%20which%20version%2Fbuild%20of%20Windows%2010%20are%20you%20using%3F%3C%2FLINGO-BODY%3E
New Contributor

W10 in dual monitor mode (laptop - Primary Monitor + external monitor - Monitor 2). Periodically, the laptop screen will go black, the Windows Display reverts to "show only on monitor 2", and although I can continue working on monitor 2, the laptop just "seems" dead. It is not dead at all however, since if you run the DETECT in the display option, it immediately detects the laptop again, although strangely the browser session I had open now reverts to the laptop has now moved over to the primary monitor.

All drivers are up to date and no "bangs", and I have tried with both new HDMI cable and different monitor.

Nothing corresponding in the event logs.

 

Any assistance in troubleshooting more than welcome.

3 Replies
Hi,
just want to check, which version/build of Windows 10 are you using?

@HotCakeX 

 

1909 18363.1316

 

Confirm this does NOT happen when using just the laptop and no second monitor.

 

Even if I had some log files to check or heightened event logging ?

 

Thank you

Thanks,
I'd suggest updating your OS to the latest version too,
latest version is 20H2, it keeps getting better after each update,
you tried a new cable but made no difference, so why not trying a new OS version :)