Windows 10 pro client dpi scaling not working (RDP)

%3CLINGO-SUB%20id%3D%22lingo-sub-1793368%22%20slang%3D%22en-US%22%3EWindows%2010%20pro%20client%20dpi%20scaling%20not%20working%20(RDP)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1793368%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20use%20a%20Macbook%20to%20RDP%20to%20Windows%20laptops.%3C%2FP%3E%3CP%3EI%20have%20both%20Windows%2010%20Enterprise%20and%20a%20Windows%2010%20Pro%20laptops.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20%22IgnoreClientDesktopScaleFactor%22%20is%20NOT%20working%20in%20the%20Windows%2010%20Pro%20laptop.%20I%20am%20not%20able%20to%20set%20a%20custom%20scaling%20on%20this%20one.%20You%20can%20see%20the%20scaling%20was%20set%20to%20150%25%20in%20the%20native%20laptop%20display%2C%20but%20when%20I%20remote%20login%2C%20the%20scaling%20goes%20back%20to%20100%25.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20works%20fine%20in%20the%20Windows%2010%20Enterprise%20laptop.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWindows%2010%20Pro%20with%20incorrect%20scaling.%20Native%20Scaling%20%3D%20150%25%2C%20but%20remote%20scaling%20goes%20to%20100%25%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22nYqUiStSeNsEi_1-1603043904822.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F227497iEE1142702BF4B8D0%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22nYqUiStSeNsEi_1-1603043904822.png%22%20alt%3D%22nYqUiStSeNsEi_1-1603043904822.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWindows%2010%20Enterprise%20with%20correct%20scaling.%20Native%20scaling%20%3D%20Remote%20scaling%20%3D%20150%25%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22nYqUiStSeNsEi_2-1603044071719.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F227498iB15FACCBCDB82C01%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22nYqUiStSeNsEi_2-1603044071719.png%22%20alt%3D%22nYqUiStSeNsEi_2-1603044071719.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20both%20the%20cases%2C%20I%20am%20remote%20logging%20into%20these%20laptops%20with%20a%20Full%20HD%20external%20monitor.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20help%20with%20the%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hello,

 

I use a Macbook to RDP to Windows laptops.

I have both Windows 10 Enterprise and a Windows 10 Pro laptops.

 

The "IgnoreClientDesktopScaleFactor" is NOT working in the Windows 10 Pro laptop. I am not able to set a custom scaling on this one. You can see the scaling was set to 150% in the native laptop display, but when I remote login, the scaling goes back to 100%.

 

This works fine in the Windows 10 Enterprise laptop.

 

Windows 10 Pro with incorrect scaling. Native Scaling = 150%, but remote scaling goes to 100%

nYqUiStSeNsEi_1-1603043904822.png

 

Windows 10 Enterprise with correct scaling. Native scaling = Remote scaling = 150%

 

nYqUiStSeNsEi_2-1603044071719.png

 

In both the cases, I am remote logging into these laptops with a Full HD external monitor.

 

Please help with the issue.

 

Thanks!

 

 

0 Replies