Windows 10 IPv6 Ping and Traceroute returns from my router rather than target site

%3CLINGO-SUB%20id%3D%22lingo-sub-1560279%22%20slang%3D%22en-US%22%3EWindows%2010%20IPv6%20Ping%20and%20Traceroute%20returns%20from%20my%20router%20rather%20than%20target%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1560279%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20enouctering%20a%20strange%20issue%20with%20ping%20and%20traceroute%20via%20IPv6%20on%20serveral%20Windows%2010%20Pro%201909%20machines%20on%20my%20network.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20ping%20an%20external%20IPv6%20host%20from%20one%20of%20the%20PCs%20the%20response%20appears%20to%20come%20back%20from%20my%20router%20based%20on%20the%20response%20time%2C%20rather%20than%20the%20host%20site.%20For%20example%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-yaml%22%3E%3CCODE%3EC%3A%26gt%3Bping%20google.com%0A%0APinging%20google.com%20%5B2404%3A6800%3A4006%3A810%3A%3A200e%5D%20with%2032%20bytes%20of%20data%3A%0AReply%20from%202404%3A6800%3A4006%3A810%3A%3A200e%3A%20time%3D1ms%0AReply%20from%202404%3A6800%3A4006%3A810%3A%3A200e%3A%20time%26lt%3B1ms%0AReply%20from%202404%3A6800%3A4006%3A810%3A%3A200e%3A%20time%26lt%3B1ms%0AReply%20from%202404%3A6800%3A4006%3A810%3A%3A200e%3A%20time%3D1ms%0A%0APing%20statistics%20for%202404%3A6800%3A4006%3A810%3A%3A200e%3A%0A%20%20%20%20Packets%3A%20Sent%20%3D%204%2C%20Received%20%3D%204%2C%20Lost%20%3D%200%20(0%25%20loss)%2C%0AApproximate%20round%20trip%20times%20in%20milli-seconds%3A%0A%20%20%20%20Minimum%20%3D%200ms%2C%20Maximum%20%3D%201ms%2C%20Average%20%3D%200ms%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3ESimilarly%20if%20I%20attempt%20a%20traceroute%20it%20completes%20at%20my%20router%20after%20one%20hop%20(note%20have%20replaced%20my%20router%20address%20with%20example%20IPv6%20address)%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-yaml%22%3E%3CCODE%3EC%3A%5C%26gt%3Btracert%20-d%20google.com%0A%0ATracing%20route%20to%20google.com%20%5B2404%3A6800%3A4006%3A810%3A%3A200e%5D%0Aover%20a%20maximum%20of%2030%20hops%3A%0A%0A%20%201%20%20%20%20%26lt%3B1%20ms%20%20%20%20%26lt%3B1%20ms%20%20%20%20%26lt%3B1%20ms%20%202001%3Adb8%3A1234%3A1%3A%3A1%0A%0ATrace%20complete.%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3BIt%20makes%20no%20difference%20whether%20I%20use%20the%20FQDN%20or%20the%20IP%20address%2C%20or%20if%20the%20IP%20address%20is%20incorrect.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOther%20Windows%2010%20machines%20don't%20have%20the%20same%20issue%20and%20can%20ping%20and%20traceroute%20IPv6%20hosts%20outside%20of%20my%20network.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20at%20a%20loss%20to%20explain%20why%2C%20and%20can't%20find%20any%20similar%20issues%20when%20searching%20online.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I'm enouctering a strange issue with ping and traceroute via IPv6 on serveral Windows 10 Pro 1909 machines on my network.

 

If I ping an external IPv6 host from one of the PCs the response appears to come back from my router based on the response time, rather than the host site. For example:

 

C:>ping google.com

Pinging google.com [2404:6800:4006:810::200e] with 32 bytes of data:
Reply from 2404:6800:4006:810::200e: time=1ms
Reply from 2404:6800:4006:810::200e: time<1ms
Reply from 2404:6800:4006:810::200e: time<1ms
Reply from 2404:6800:4006:810::200e: time=1ms

Ping statistics for 2404:6800:4006:810::200e:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

Similarly if I attempt a traceroute it completes at my router after one hop (note have replaced my router address with example IPv6 address)

C:\>tracert -d google.com

Tracing route to google.com [2404:6800:4006:810::200e]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  2001:db8:1234:1::1

Trace complete.

 It makes no difference whether I use the FQDN or the IP address, or if the IP address is incorrect.

 

Other Windows 10 machines don't have the same issue and can ping and traceroute IPv6 hosts outside of my network.

 

I'm at a loss to explain why, and can't find any similar issues when searching online.

0 Replies