Windows 10 1809 Hyper-V Broken?

Occasional Contributor

I upgraded from 1803 to 1809 last week, before Microsoft withdrew 1809. Everything was fine as far as I could tell. Until today. Today I opened Hyper-V Manager so I could start my Windows 8.1 VM. When I open the Manager, though, it doesn't seem to think I have Hyper-V running on my system. All I have in the console is the option to connect to a server. When I try to connect to my local computer, I get the error "An error occurred while attempting to connect to server "xxxx". Check that the Virtual Machine Management service is running and that you are authorized to connect to the server." The service is running and I'm the admin on this server so I guess I'm authorized. It worked up until this upgrade.


Any clues as to what might be going on?




4 Replies
best response confirmed by Rob Moore (Occasional Contributor)

Ran into this one myself.

Found the answer at


Start -> Settings -> Update & Security -> Windows Security -> App & browser control -> [Exploit Protection] Exploit protection settings -> [Program Settings] [Find C:\WINDOWS\System32\vmcompute.exe and expand, then] -> Edit -> [Code flow guard (CFG)] UNCHECK 'Override system settings'


Start vmcompute service from services or command line with 'net start vmcompute'

Thanks! That fixed it!



@Andy Hufford 


By the way, I had just upgraded a Windows 10 Enterprise laptop to 19H1/1903 and had a similar problem (Hyper-V management not starting). This fix worked for me. 

Thanks for this suggestion - it's the first solid useful suggestion for why Hyper-V has been broken for me since last November or thereabouts. I'll be directing people here in future.
I found that I also had to disable Control Flow Guard protection on the 'vmwp.exe' process. Once I had done this, I simply restarted, and Hyper-V works again. Irritated that I didn't find your solution last year!