Windows 10 1809 Edge not loading pages

Senior Member

After updating from 1803 to the new 1809 release Edge stopped working (as well as the Feedback hub), while Chrome and Firefox continued to work fine.

 

After some trial and error the culprit ended up being that the IP6 protocol was disabled on my wireless adapter - I'd turned it off for some other testing and apparently that stops Edge from working entirely.

 

Just putting this up here for anyone else that runs into this problem. It seems that issues with Edge not working after updating to 1809 have been going on for some time in the pre-release rings so I'm surprised that this hasn't been resolved yet.

54 Replies

In my case MS Edge does load web pages in Win 10 Pro on my Dell XPS8700 mid tower system, but certain website do not load properly.  Amazon.com does not show the TV show or movie watchlist properly. Menu items are listed down the left side of the page and movies are big boxes in the middle of the screen with lots of space causing need for lots of scrolling instead of horizontally in rows across the screen.  I just updated to 1809 on my Dell Inspiron Laptop and before the update to 1809 Edge showed the web pages correctly and after the update the same issue of the Dell XPS8700 mid tower began. IVP6 is checked so that is not the problem. In addition some web pages load very slowly. Can anyone help or are we waiting for Microsoft to fix that problem?

@Dwight Williams 

 

Just upgraded a couple of systems to 1903 and seeing this issue for the first time. Changing network from Private to Public works when on an outside connection, but these are domain-joined machines on a domain network, so Edge is effectively broken for them

@Brian Illner Same issue. Just updated to 1903. Domain joined. All updates applied. Doesn't matter if IPv6 is enabled or not (seems like an odd thing to break a browser anyway). Just started digging in to this, but it's got to be a bug.

 

Edit: Also reset and repaired Edge to no avail.

I have not solved this issue yet, but another few odd things I've found...

1. Microsoft Store opens, but does not load any page.
2. If I manually set the DNS on my machine to an external DNS server rather than use our local DNS, Edge and the MS Store work fine. I even set my machines DNS to use the same forwarders as our local DNS does. Edge and MS Store work fine.

Seems to me like there is an issue with this build of Windows and how certain apps handle DNS. At least Edge and MS Store.

@nizbot 

Same issue.  Domain joined Edge only works for Trusted sites.  Public network all works fine.  If you want to break IE11 the same way, just Enable 64-bit processes for Enhance Protected Mode and Enable Enhanced Protected Mode in Internet Options.  If I could just find out how to disable EPM for Edge, maybe that would fix this issue.

@NMSU92 Thanks. Please let me/us know if you figure it out. For me this is not terribly pressing since 1903 hasn't made its way on to the majority of my client machines, it's only Edge and the Windows Store, and I have better things to focus on O.o

I opened a ticket with Microsoft support over a week ago. No luck yet. I have an external DNS entry in my DHCP settings that allows Edge to function as well as Microsoft Store. Not a permanent fix, but a band-aid until MS hopefully finds a solution.

Other reports are out there, this one claims he found a solution through GPO in his particular case.

 

https://social.technet.microsoft.com/Forums/en-US/51485aa1-867a-42ee-8fc9-0fee4c6fd651/windows-10-19...

 

 

@Gavin Gregson 

 

Reset Edge browser Press Windows + X then select settings, Next, under the Apps and features section, search for Microsoft Edge. Now click on the Advanced options link to open the following window. first, select the Repair option if Edge is not working properly.

@Gavin Gregson 

 

Following worked for me!

 

I have only 1 user on my pc, that is administrator a/c created by the windows 10 installation.  I never bothered to create any other a/c as I did not required.

 

After the update of 1809, edge browser was unable to show web pages. For pages such as (https://fast.com) it was just showing endless circles..

 

Solution that worked for me: Created a user a/c. In that a/c, web pages are working fine!

 

Good luck!

 

 

Yes, disabling ip helper and rebooting does allow Edge and store to work again. You do get some errors when you do a gpupdate though. Nothing breaks as fa as I can tell. Will implement this until MS finds a fix.

@Gavin Gregson 

I have the same problem BUT I am working on a desktop with a direct LAN connection. Not WiFi

Occasionally restarting the PC solves the problem for a few days. Then it recurs

I hoped the new Edge release would solve it. But nope!

deleting and reinstalling did not work

 

any more ideas?

The new Microsft Edge will resolve the issue that you are having. The older MS Edge is now classified has a legacy Edge. This new Edge updates every 6 weeks and is based on Chromium. This new browser is significantly faster and more reliable the it's predecessor.

@Gavin Gregson 

 

i found one solution which was to switch the network from private to public..  but that I think turns off printer sharing... we shall see if this is a problem

It is the new Edge that I have just had the issue with. I turned on IPV6 and it resolved the issue. I only had a problem since returning back on site and using the docking station. Chrome still worked fine so there is come issue with the new edge and something in networking.

O/S is 1909 Windows 10 enterprise.