Windows 10 1803 to 1809 Hyper-V - Cannot Start any virtual machines

Highlighted
Occasional Visitor

Hi All

I upgraded my Windows 10 machine from 1803 to 1809 yesterday. All appeared to be fine until I came to start a VM. I can connect to the VM but when I press start it appears to start then just stops - in a matter of seconds. No error messages are displayed and it doesn't matter if I start the VM from Virtual Machine connection or the Hyper-V console, the behaviour is the same.

 

It doesn't matter if try and start a Windows guest OS or a Linux Guest OS both behave the same, I've upgraded the VM configurations just in case - all to no avail. 

 

These machines were working fine under 1803

 

I've searched the hyper-v logs and found these errors in the worker logs

EventId 18560

'VM15' was reset because an unrecoverable error occurred on a virtual processor that caused a triple fault. If the problem persists, contact Product Support. (Virtual machine ID.....

 

EventId 18604

'VM15' has encountered a fatal error but a memory dump could not be generated. Error 0x2.  If the problem persists, contact Product Support for the guest operating system.  (Virtual machine ID....

 

I've tried these Fixes even though they're not really the same problem and in fact I had to add vmcompute to the list apps to uncheck the override.  So effectively adding the app to say no overrides?? - I tried restarting VMcompute and restarting the machine after the fix but it didn't work.  

 

https://techcommunity.microsoft.com/t5/Windows-10/Windows-10-1809-Hyper-V-Broken/m-p/269352
https://social.technet.microsoft.com/Forums/en-US/ee5b1d6b-09e2-49f3-a52c-820aafc316f9/hyperv-doesnt...

 

-https://techcommunity.microsoft.com/t5/Windows-10/Windows-10-1803-to-1809-Hyper-V-Cannot-connect-to...

 

I found this article

unrecoverable-error-occurred-on-a-virtual-processor-that-caused-a-triple-fault

 

Which suggests that the problem could be down to power saving or CPU problems 

- I am running on a laptop but I'm plugged in to the mains and the power profile if full performance - this hasn't been a problem for me in the past even when running on battery.  

- I ran the Intel Processor Diagnostic tool and that has given the processor a clean bill of health - all tests pass.

 

I haven't tried Uninstalling / Installing Hyper-V yet.

 

Edit: I Have just tried creating a new Ubuntu VM (Quick create) and that works so it appears that the problem is something to do with the configuration or settings of my old/existing VM created prior to the 1809 upgrade.

 

Any help or assistance would be much appreciated.

 

Kind regards

Mark.

 

1 Reply