Windows 10 1803 to 1809 Hyper-V - Cannot connect to the virtual machine

Copper Contributor

Windows 10 1803 to 1809 Hyper-V - Cannot connect to the virtual machine

Hi all,

After upgrading from Windows 10 1803 to 1809 I am no longer able to connect to any running VM's.
I am able to start the VM and see it running in the preview screen but when attempting to connect to the VM, I receive "Cannot connect to the virtual machine. Try to connect again. If the problem persists, contact your system administrator. Would you like to try connecting again?"


I didnt have any such issues when running 1803.


There are a few articles I came across on here which don't seem entirely accurate to my issue. However I have also tried the fixes.



Things checked

- Both Hyper-V Virtual Machine Management and Hyper-V Host Compute Service services are Running
- ESET Antivirus - turned off/disabled
- App & browser control > Program Settings > vmcompute.exe, vmconnect.exe, vmwp.exe disabled CFG override system settings
- App & browser control > System Settings > CFG, DEP, ASLR & SEHOP set to Off by default - still fails
- User is a member of Hyper-V Administrators group
- Upgraded a VM configuration version from 8.3 to 9.0 - still fails
- Created a new configuration version 9.0 VM - still fails
- Launched virtmgmt.msc as normal (and run as administrator) - still fails
- Launched vmconnect.exe as normal (and run as administrator) - still fails


I haven't gone as far as uninstalling/re-installing all the hyper-v components yet


Any help or assistance is much appreciated.


Kind regards,



16 Replies
Hi Mark, I've exactly the same issue. Were you able to get an answer? Thanks!

Since 1809 upgrade on my Win 10 Pro system when I launch Hyper-V manager and try to connect to my server it site there for like 1-2 min then put ups an error telling me to check the server. What crap every semi-annual update has broken some aspect of RSAT or remote management tools, how hard is this MS! I understand why people stick with LTSB versions now , far more stability!

@hdtvguykeiththanks for your post! Maybe we're missing something idk... Microsoft must have the same issues internally. Since my original reply, I have rebuilt machine and now am running latest insider builds on host and on both VMs with the same outcome. Have noticed though if not using enhanced sessions, sometimes can connect to VMs through console, otherwise just RDP into their ip.

After updating from 1803 to 1809, I am no longer able to connect to NEW VMs I create using the Hyper-V Manager.  However, all my my VM's that were created before the upgrade still work as before.


I noticed that in the VM settings dialog, RemoteFx 3D  Video Adapter is now grayed out with the notice:


"We no longer support the RemoteFX 3D video adapter.  you can keep using this adapter on existing VMs, but you can't apply it to any new VMs."


While I am not using RemoteFx, I am curious if the deprecation has broken the Hyper-V Manager Virtual Machine Connection ability.


They appear to have fixed it and should be available in next updates.
Connected through console in the Insider build and it worked as before.

I ended up performing a clean install of 1809 and it was working for a few weeks on my existing VM's. All of a sudden, I hit the exact same issue again.

I migrated away from Hyper-V to VMware workstation in the end.
Glad to see they identified the issue and will be fixed in a future release.

Hi All,


Is there any progress with this issue? I updated with the new updates and i facing the same issue.

I've been having this issue since a couple of weeks now. I'm running 1903.

Any updates?

Just upgraded my Workstation to 1903, and now i cant connect to my Hyper-V server that was hosting all my VMs. I get an error say to check the server to make sure the basic services are running and that WinRM cant complete the operation. Nothing has changed, beside me moving to 1903. 

Has anyone figure out what needs to be done to get a connection back. I really don't want to RDP to each one of my VMs that i have created for testing, as i have 5 other people that use this too.

So i was just digging and found that my Server got a patch that disable Windows Remote Management Service. I re-enable and turn it back to auto-delayed like i had it. Then started the service and everything came right back to life. I also add the Hyper V adapter to public firewall, but i don't think that did anything.

@AMoeller88 That doesn't work for me, unfortunately.

@Vic_U I know this is an old thread I initially started, but I had the exact same issue migrating from Windows 10 1909 to 2004.


I did come across an article with a registry fix, changing the ListenerPort dword from 2179 to 21791 under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Virtualization. After stopping/started the hyper-v windows services I was able to connect to the virtual machines as normal.

@M Gibson correct and thanks for this fix, I changed the ListenerPort dword from 2179 to 21791 and was able to access the new VM. I have the most update-to-date win10 20H version.

Can somebody from MS indicate why this happens from time to time and if we should keep this different port?

Hi @Maitre Elias I believe its to do with the reserved ports within Windows. Hyper-V seems to aggressively reserve a large range of ports.


At a command prompt, if you type netsh int ipv4 show excludedportrange protocol=tcp it will show the port exclusions. One of which is a range which contains port 2179.


You can run netsh int ipv4 set dynamic tcp start=51001 num=5000 which will reset the dynamic port range to start at 51001 which is a range applications typically have no port reservations to bind to.


Followed by running reg add HKLM\SYSTEM\CurrentControlSet\Services\hns\State /v EnableExcludedPortRange /d 0 /f which disables the HNS (Windows Container Host Networking Service) port exclusion behaviour.


Set your Hyper-V port back to the original value of 2179 and reboot your computer. You should now be able to launch Hyper-V, start a VM and connect to it.


Hope this helps you and others. Here are the links to the sources on the issue/fix:


@M Gibson so many thanks, I will do but I have one concern, I use docker desktop on the win 10 box, so if I disable the HNS port wouldn't this affect how containers/docker work?

Hi @Maitre Elias. I also run docker desktop with both the docker and kubernetes engine service on Win 10 20H2 and so far, I haven't run into any issues.


Hope this helps