Why Does System Restore Never Work in Windows 10?

Copper Contributor

I have tried System Restore on multiple Windows 10 Pro machines over the past few months, and it has never, ever worked. Usually, it takes an hour or two before it gets the whole way through, and then it inevitably fails. System Restore is turned on and has multiple restore points. Even if I try a different restore point, I get the same result. Is there some way of making System Restore work? All of these different machines can't possibly have corrupted hard drives or malware or some other problem. Thanks in advance.

11 Replies
The below link can help you to troubleshoot.

Overview of 'System Restore did not complete successfully' issue

It used to work sometimes but now it NEVER DOES.

Error messages are USELESS!!!
Useless info.

@ComputerBeeBecause Microsoft Windows is more of a sales pitch than an operating system. Windows has been absolute garbage since the release of windows 10. It's invasive, restrictive, and most of all Bloated. Half of the "features" either break half way through, Don't work in general, or stop you from outright fixing any problems you have yourself.
  Linux is very close to being a viable alternative at this point. I've been waiting 3 years for it to catch up, and it's very close to the cusp. Within 10 years, this site will be nothing but a garbage dump of useless replies that never helped anyone (it basically already is). I've never seen one answer from a "technician" here that actually helped anyone fix their problem. Just a generic response, and the question gets answered by someone else in the thread who managed to circumvent the problem in their own way.
  Here's to the future.

HI ComputerBee, I have never had a issue with Windows Restore points as it always went back to the past point :) Are you on the latest version of Windows?

Shawn is a fake account for sure...

Yeah, System Restore never has worked for me. For reference I have 2 machines running 10 Pro in development mode and a third running 11 pro.

Dear Microsoft;

Quit asking people what version they are on and fix your BROKEN **bleep** SHIT.

Remote desktop somehow magically got corrupted when I needed it most, my only recommendation from your half-assed support?

System Restore...WHICH DIDNT WORK. My server is down right now because Windows 11 is a fail.

I'm out 5 **bleep**ing days of work.

I might just have to switch to Linux, but I'll be contacting your sales team about a refund for my business.

Idea of the century for Microsoft, maybe if you didn't spend so much time collecting my data your operating system would be worth the $200+ pricetag. It feels like Everytime I get hardware gains, Microsoft finds another way to tack on another form of data collection.


Take a hint...you started doing subs for office, now I just use sheets...everyone else is just a tool. I hope windows goes to a subscription so the general public can be done using you as a standard.


I have really have done many restore points before to test out an app or before I do any updates to the computer like a driver or with a support agent that helped me with a software issue.

It usually always restarts and go back to the way it was before the restore point, it still works today :)

Kindly report this through Feedback Hub, also have you used the QuickAssist app?

I am not familiar with the Remove desktop app,

Thank you :)


I've used windows for over 20 years bud.

I'm a bleeding edge user.

You can passively aggressively insist your system Restore works on your home or oem edition windows, no one cares.

OP has a point, and you're just here shilling for Microsoft for goodboy points, or so Microsoft doesn't have to actually answer our question or fix their product.

Go away fake. ";)"


Linux system Restore works 99% of the time regardless of the system. Why doesn't windows?

Hi DrCosmar,

May I ask what is the error with the system restore point, can you make a video of the issue so I can find out how to fix it?

I really do want to help you out here, I am trying to help as many people as possible! I am using Windows 11 Professional and it's not special.

I am not a fake,
I appreciate the sentiment, but I just reset the PC instead. That always seems to work.

If I hadn't neglected it I would provide you with the error information, but I was pressed for time and only tried twice.

System Restore has never worked for me anytime I have been asked to use it. I understand it might work well for you, and work well for others. It does not for the people proclaiming so here.

Such a critical function shouldn't need troubleshooting. If you are using it, chances are you are past the point of troubleshooting the initial issue anyways.

I concur.  I have never gotten restore point to work in Win 10, over several years, on a desktop or on a laptap.  Attempting restore, after several minutes the error message only reads something about 'unable to complete restore,' and does not indicate the problem or solution.  This problem occurred across all Win10 updates, and I have plenty of drive space, no viruses, and system/drive checks all show ok.  Have not found a solution.