W10 Pro - Mapped network drive fails to connect at startup

Copper Contributor



I have just changed to Windows 10 Pro from 7 Pro on another laptop. On W7 my mapped network drive worked without any problems. That is not the case with Windows 10 Pro.


After opening Explorer there is a red X on the drive icon. Sometimes when I click it I get a message saying a connection cannot be made. But 8/10 times it will connect. So if it can connect why the red X?


The drive in question is a Synology DS212J NAS box and I have a mapping to a folder named Backup which contains many sub-folders. This is standard hardware, nothing special.


Given Windows 10 has been out for a couple of years I'm surprised I'm having these problems. I have searched for solutions and tried a few but to no avail. Can you help please?

7 Replies

Can you see if that NAS box supports SMBv2 and v3?  It's more than likely the NAS is set to support SMBv1 and thus failing.

Hello Susan,


I wouldn't know where to check for that, sorry. But just to clarify, whilst there's a red x against the mapped drive letter in Explorer if I click it then the folders are displayed. So it's not an access issue as such, just W10 showing the status as not connected.


It's only a problem if I open Money and then on closing it where it's backed up to that drive it reports the location as inaccessible. I then have to click the drive letter in Explorer to clear the red x. Then the Money backup is okay.

Sounds like it's the typical Windows autodisconnect feature that can be turned off.  

best response confirmed by Ray Proudfoot (Copper Contributor)

At an elevated command dos prompt type in net config server /autodisconnect:-1 and hit enter

Thanks Susan. Did that and on opening Explorer there was no red X against he mapped drive. Hopefully that will continue to be the case.

I initially pressed Windows Key + R and entered cmd.exe. But the command didn't work presumably because I didn't have Admin Rights. But mine is the only account with Admin privileges so shouldn't the privilege been granted automatically as it was in W7?

Separate issue I know but just curious. Thanks for your help, much appreciated.

Admin rights are not the same as what's needed for run as admin.  That UAC pop gets you to the proper spot.

A subtle but important difference!