W10 H21 upgrade from W7 - Can't get past Location setting screen

Copper Contributor

Hi - Really hoping someone here can help.  I've just upgraded my old but high-spec Lenovo W540 that hasn't been working (long story) from W7 Pro to W10 Using the media creation tool.  It's gone straight in on the H21 build - great - but now I can't get past the Set your Location screen.  I DO NOT want to configure this.  The problem is it comes up as a white screen with a  plain text as below and stays on top of everything else.  The tiny square underneath is the Ease of Use button and there's one on the other side of the screen for Volume.  Hitting Accept does nothing but grey out the button.  I have all the registry settings for notifications turned off (done in Safe mode) but the Notifications settings in the Settings App keep staying on.  It's an all-user issue - I have 3 local accounts on the laptop and it's the same on each.  This is driving me mad - I was thinking of going to W11 after this upgrade but not sure now.  Wondering if I can put a PowerShell script in the Startup folder or RunOnce reg setting and turn this off under the full user environment?  Being the Text version though it shows with no hyperlinks I can't do anything with it.  I can run things like Task Manager but they stay behind this screen so I can't bring it to the front and kill it.  I've tried all suggested solutions out there - registry; GP settings; Notification settings, etc, nothing seems to kill it off.  It does not appear in Safe Mode.  Anyone seen this before and know how to get rid of it?




6 Replies

So I've been carrying on this afternoon - I've tried opening another clean desktop and switch to that - nope. I can do a Win+R and so I can open an elevated cmd which comes up behind the page above or PowerShell and so I can run commands there - not sure how useful that is atm as I can't read the outputs - too small. Can also open pretty much anything but it all stays behind this page. Event log not much help. If I knew what the process was called I could stop it from starting in the first place. msconfig reboot with startup disabled - no change. Disabling things one at a time is getting really tedious. It's so incredibly frustrating I'm now considering ditching W10 altogether and going back to Linux. Just this one thing that's seriously ruining it so far.  Untill this is done I can't really run the Lenovo BIOS or driver system updates.

Where do you see this screen?
Is it during the Windows Setup?
This is not a normal screen with the Windows installation and may be some components are missing.
Did you create a bootable media using Windows Media Creation tool or you used any third-party tools?
Did you download it from the official Microsoft website?

Just the MS Media Creation tool - nothing else. Ran the Upgrade Now option. No errors reported, it all ran smoothly until I logged in for the first time. I also thought - judging from the text format - that there were some components missing. Until I get past this I can't really do much. Safe mode is hobbled so can't do much from there.  I get this evert time I log in on every account.  Just not safe mode.


Edit: Going to re-run the media Creation tool and build an ISO - maybe do a repair and see if that finds anything.  I'm an infrastructure guy so don't normally touch desktop OS's, been ages since I did a W10 install.  VMware, W2016 and 2019 vms all the time.

You are right there is something wrong with the Windows.
Do you have access to the command prompt?

@Matt Halliday  Hi

I think that the system is fine, this is not a system message, this software from the manufacturer blocks in my opinion - Lenovo Ventage, or another application preinstalled with high permissions I also have such a computer, I have it uninstalled and works well

Yeah - got it. Got Task Manager on top. It showed as Windows "Account" - I killed everything one at a time and that's what did it. Thanks for the assistance. Laptop works fine now. It's a high-spec custom build from 2014. I had it built when I was contracting and had all the toys including the Pantone Screen Calibration and the very high res screen. I'm a photographer as well so wanted the colour correction. Just got to put it all back together now.