Tech Community Live: Windows edition
May 31 2023, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Virtualization - Legacy Bios and UEFI issue

New Contributor

Hi everyone, 


My issue is I want to convert from legacy BIOS to UEFI so that I can enable virtualization to run virtual machines. I've done some research and my processor & motherboard both support UEFI. Currently my BIOs has no settings allowing me to choose UEFi. I've updated my BIOs to the latest version but still no new features were added. 


I tried to convert my hard drive from MBR to GPT which I was successful in doing but after I did this. I couldn't boot up. To fix I then had to revert the conversion back to MBR and do a fresh installation of windows. 


Now I'm here with a fresh windows installation with no clue what to do. I'm relatively new to all this so apologies if I'm unclear.


System specs:

AMD FX(tm)-4350 Quad-Core Processor

Motherboard  - M5A78L-M/USB3

Graphics Chipset - AMD Radeon HD 7700 Series

Windows Version - Windows 10 (64 bit)
Memory Size - 1024 MB
Memory Type - GDDR5
System Memory - 8 GB


Currently on legacy


Thank you 




4 Replies
best response confirmed by smccarrick (New Contributor)
The reason why your computer couldn't boot up after converting your Hard Disk to GPT is because your motherboard was still using the old BIOS, so it couldn't boot from GPT.
so first you need to get a Motherboard that has UEFI already on it. any decent motherboard from the last 5 years already has UEFI preinstalled.
Your motherboard is too old. If you check its specifications on Asus page they doesn't list UEFI in BIOS section like they do for new motherboards.

@HotCakeX Thank you for your response I ended up changing the hard drive back to its original state. I think its time for a new motherboard! 

@wroot Hi Oleg, I think I misread the specs for it because it did say it supported some form of virtualization so I presumed it had UEFI support.