SOLVED

Remove Google Sheets, Docs, Slides entries from "New" context menu

Occasional Contributor

Since I use Microsoft Office 365 on my Windows 10, 11 PCs, I never use the Google tools Docs, Sheets, Slides. Unfortunately I just need Google Drive and Fotos since my Google Pixel smartphone doesn't allow photos and videos to store within Microsoft OneDrive which is my standard cloud.

Nevertheless I have Docs, Sheets and Slides within the "New" context menu (right click anywhere). They do nothing but occupy space and thereby block out useful new-options like Excel.

I found no regular way to get rid of those entries. Would it be save to discard the .gdoc, .gsheet, .gslides registry keys within HKEY_CLASSES? Or at least their ShellNew subkeys?

I read somewhere that they will appear again after a while. Google seems to force those menu items.

10 Replies
In case you are concern about your mobile phone, you may download OneDrive and Microsoft Office app for Android devices too and you could use them instead of the Google products.
In case you installed Google products in your Windows, you may uninstall it from App menu in Settings.

@Reza_Ameri 

I know all that. I'm afraid you misunderstood my issue. It has nothing to do with my smartphone. I mentioned that only for explaining why I have to use Google Photos and hence Google Drive. Let aside Google Drive and Chrome I have no Google Apps on my PC. I do not use Chrome, but Edge. Maybe I should uninstall Chrome?

My issue is: How to get rid of those Goggle Docs, Sheet, Slides entries in the Windows context menu?

Would you mind take a screenshot and reply to this post and paste them?
Are you able to right click and delete them?
best response confirmed by Werner_Geiger (Occasional Contributor)
Solution
I think I solved that issue: Within the registry HKEY_CLASSES delete the ShellNew subkeys of .gdoc, .gsheet, .gslides.

@Werner_Geiger

Hi Werner,

I'm having the same frustration and I have even created a .reg file to do that automatically but unfortunately the GoogleDriveFS.exe file puts them back.

I tried renaming GoogleDriveFS.exe but that causes other problems within Google Drive so as it stands Google wins and I just have to ignore them.

Here's the .reg file if you're interested.

Create a notepad.txt file and change the extension to .reg

I think I have just come up with Google's next slogan... "Resistance is Futile"

BTW, I'm using Win7 but I think it makes no difference.

Cheers

===================================

Windows Registry Editor Version 5.00

 

[-HKEY_CLASSES_ROOT\.gdoc\ShellNew]

 

[-HKEY_CLASSES_ROOT\.gsheet\ShellNew]

 

[-HKEY_CLASSES_ROOT\.gslides\ShellNew]

 

[-HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\GDContextMenu]

 

[-HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\GDContextMenu]

 

[-HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\GDContextMenu]

===================================

 

 

 

Deleting the keys from the registry or using a 3rd party context menu editor only works temporarily as the GoogleDriveFS.exe file recreates the registry keys within a minute. G'Dam Google!

@G_Sau 

 

Hello G Sau

 

That is everything correct and infuriating. But I found the solution!

 

First, you have to find 3 keys.

 

[-HKEY_CLASSES_ROOT\.gdoc\ShellNew]

[-HKEY_CLASSES_ROOT\.gsheet\ShellNew]

[-HKEY_CLASSES_ROOT\.gslides\ShellNew]

 

Second, you have to remove all entries below (Default).

 

Third, you must be quick now! Right-click on the key (ShellNew), hit Permissions and a new window will open. Select Administrators (lowest entry in Group or user names), Deny Full Control and hit Apply.

 

I don't know why this Google Drive software is so aggressive, I just find the fact very disturbing and the company is not honest at all if you ask them for their reasons...

@Texxi 

Hi Michael,

Mate, you are a legend!

Changing the permissions was the missing piece to the puzzle.

While I'm pretty savvy at PC 5hit, your instructions were very clear and easy to follow.

 

The following is for the benefit of anyone else looking to understand how to control this problem caused by Google and pretty much any other aggressively intrusive software program.

 

After changing the permissions, the string values did not return - even after refreshing numerous times. Normally they will return.

To prove your solution, after several minutes of no return from Google, I went back and allowed the permissions of just one of the keys and the string value returned immediately.

I also tried denying permissions before deleting the string value and it disappeared. But reappeared when I allowed permissions.

As I mentioned, this solution should work for any software that recreates nuisance string values in the registry.

 

Thanks Michael, I learned something really useful today.

Cheers!

 

 

 

@G_Sau 

 

I'm glad it worked for you. I had to reinstall Windows yesterday, so I'm going through the same troubles again. Only this time, I'm going to block even more pesky things. There is one related to Google Drive, so I thought I'd share the solution here. Google Drive always mounts itself as a Virtual Drive G: containing just a link to your actual Google Drive Folder, which, if you ask me, is complete nonsense. I mean, really, what purpose does it serve?!

 

 

I found this article in the Google Workspace Admin Help: https://support.google.com/a/answer/7644837?hl=en&dark=1 

 

 

To apply this simple fix, navigate to the following Registry Key and create a new String Entry:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Google\DriveFS

 

regedit_ARWYjTyx61.png

Nice solution, but BEWARE of the potential side effects! On my W11 machine, changing/revoking these registry permissions caused my desktop and explorer windows to annoyingly 'refresh' every couple of minutes as GoogleDriveFS.exe attempted to unsuccessfully rewrite the deleted values. Restoring the permissions reversed the refresh issue. Personally, I'd prefer NOT to have blinking desktop icons every few minutes! It took me forever to finally figure out what was causing the annoying desktop refresh! Don't be fooled. -JT