"The specified user does not have a valid profile" error on apps downloaded from Microsoft Store

Brass Contributor

Hi all,


We just updated from 1607 to 1709 in our production environment.  I reimaged my machine recently to 1709 and went to the Windows Store to download the Windows Configuration Designer app.  Upon launch, I get a message pointing to the installed exe in C:\Program Files\WindowsApps and stating "The specified user does not have a valid profile".  I tested this with iTunes, another app from the store as well, and get the same result.  A coworker of mine has the same behavior.  Has anyone else experienced this?  





34 Replies

@careduro , I don't have CloudPagingPlayer, and the workaround "move apps install dir to another place" fails due to absence of system rights :)

@careduroI too experienced this when using CloudPagingPlayer.  I had to install it for something for my University, but I uninstalled it and everything works fine.  

@sergey_voronov1745 if you don't have rights to any workaround, I suppose you cannot uninstall any program neither. Maybe you should contact your administrator to fix the issue.


@sergey_voronov1745 wrote:

@careduro , I don't have CloudPagingPlayer, and the workaround "move apps install dir to another place" fails due to absence of system rights :)


@Micah Hibdon 

[just] Quitting the "CloudPaging Player" app [from sysTray] did solve this issue for me.

Had no CloudPaging player. Solved by restarting the computer couple of times until Skype gets found by typing in the Start menu.

The issue reappears about 2 times a year, same actions help. Looks like something with app updates.

I'm running into this problem since today. I've Windows version : 10.0.18362.387. I don't know if this has anything to do with User right regarding C:\Program Files\WindowsApps, because I can't access it at the moment. I'm now trying to get access to this folder, using security tab, auditing and adding my own profile. It takes a while so it's too early to say anything useful. As of today: I cannot use MS Office, Skype, Spotify or even play games for that matter. Even after installing and rebooting the computer.... I can tell you: it's pretty annoying :(

Do you have any other apps (not MS related) running in the background? I found that Cloudpaging player was the cause of my issues and once I had disabled that app, MS updated with no problems. @CynthiaFridsma 

2 years later...
I have the same issue. It gives me the error message "the specified user does not have a valid profile" and nothing I do helps. Can anyone suggest something. Whenever I try to move the folder location my computer just tells me that the system doesn't approve and it wont let me move the files from my c drive to my documents folder. Please help
This is an issue for the app "Xbox Beta" in case this helps. The image of the error message is attached.

The issue that I had related to updating windows 10 it gave me the same error message @Vuchh . It later transpired that 'Cloudpaging Player' that was running in the background prevented the windows updater completing. When I forced stopped the program 'Cloudpaging Player'  the windows updater was able to complete successfully.  This message then disappeared after the completed update and I could then run all programs as before, including Cloudpaging Player. I hope this helps.

I get this message with facebook messenger

windows 10 1909

i've tried re-installing - no luck



How did you resolve this problem. I am also experiencing it 



I have the same problem, with WhatsApp and other error was for 'Win32Bridge.Server.exe' .
I don't know what it this ,.

@Micah Hibdon 

I faced this same issue many a times recently, i read the current best answer but changing installation location might be not very practical for normal user's because they might face other issue's 

So in search of alternate solution i tried to access the read write permission of that folder and i found that while assigning the full access to the user i found out that the window showed an alert "Access Control Entry is Corrupt" you can see more on that on this forum and to fix the problem the forum redirected to me another microsoft support page  by following this System File checker i was able to elimate the problem of valid profile.


So this method worked for me;

Please reach out for any queries related to this step.

Hope this will help!!!