Problems with partitions when using MBR2GPT

Occasional Contributor

I'm not sure how to proceed to prepare for Windows 11. When running mbr2gpt, I get the following:


C:\WINDOWS\system32>mbr2gpt /validate /allowFullOS
MBR2GPT: Attempting to validate disk 2
MBR2GPT: Retrieving layout of disk
MBR2GPT: Validating layout, disk sector size is: 512 bytes
Cannot find OS partition(s) for disk 2


Here's my disk layout:


I got to this point thinking I needed to delete the Recovery Partition. It now is the 861MB Unallocated partition.

What should I do to prepare for a successful run of mbr2gpt?

My system is as follows and is running Windows 10 Pro 21H1:

AMD Ryzen 5 5600x, 32GB RAM, Asus Tuf Gaming Pro X570 Wifi


The OS being used (C Drive) was a clone of that on the G Drive. The intent of the clone is to provide a backup and to move the OS from a smaller drive to a larger, newer one.

11 Replies

Hi @Bob Arthur 

As I can see from the screenshot, following points seems pretty good for disk 2:

  • There must be a maximum of three primary partitions in the MBR partition table
  • You should not have any extended/logical partition, all three partitions must be primary partitions.
  • You must have active partition on disk 2

The following requirement is missing on disk 2:

  • There must be a system partition (OS Partition)

Please have a look and let me know your feedback.

Thank you for responding @SalmanAhmed! I very much appreciate your willingness to help.

So mbr2gpt is attempting to convert the original C drive (now G) and not finding an OS partition, even through Windows is installed on both the current C drive and the original C drive, which is now the G drive? I had thought it was going to change the disk with the OS currently being used (with the C and E partitions. That is why I was trying to delete the System Recovery for that drive, to get Disk 1 to three partitions.

I was moving to the 1 TB drive to make more room for the OS, but see that it has somehow filled up. I'm not sure how that happened but I suspect it may have to do with MS Flight Simulator having been installed (although the majority of its files should be on the E drive.

You're most welcome@Bob Arthur ,

I've just noticed that there is no target disk specified in your mbr2gpt command, please execute as below in elevated (Run as Admin) mode in cmd:

mbr2gpt /validate /disk:2 /AllowFullOS


Here it is:

C:\WINDOWS\system32>mbr2gpt /validate /disk:2 /AllowFullOS
MBR2GPT: Attempting to validate disk 2
MBR2GPT: Retrieving layout of disk
MBR2GPT: Validating layout, disk sector size is: 512 bytes
Cannot find OS partition(s) for disk 2


Hi @Bob Arthur

I would suggest you to boot your computer from the same disk (disk 2) by changing the boot order from the BIOS, and de-attach (or disable from the BIOS) all other disks, if possible. 

Disabled Disk 0 and Disk 1 in the Asus Bios. Changed Boot Order to boot from Disk 2 (500 mb disk).
Windows presented the blue screen with the option to boot from either Windows or Windows Pro. I have been booting from the "Windows" option, so I chose Windows Pro this time.
It then presented a light blue screen with the following:
Your PC couldn't start properly
After multiple tries the operating system on your PC failed to start so it needs to be repaired.
Error Code: 0x0000001
You'll need to use recovery tools ......(etc.)

Press enter to try again
Press F8 for Startup Settings
Press F9 to use a different operating system

If F8 is pressed, I get a light blue screen with ten different options. "Enable Logging" and "Boot into Safe Mode" made the most sense. I tried those. "Enable logging" results in starting again. "Boot into Safe Mode" allowed me to select either "Windows" or "Windows Pro" once again.

I tried validating Disk 1 and it returns "Cannot find OS partition(s) for disk 1".

Hi @Bob Arthur


You have to disable disk0 (931.51GB) and disk1 (931.51GB) in order to covert disk2 (465.76GB) to GPT. In other words, you have to disable both 1TB disks to convert 500GB disk to GPT. Before you do these steps, you must active 100MB partition on disk2 (465GB).

@Bob Arthur 

It is mandatory to keep an active partition on the MBR disk. The system reserved partition (which is 100MB) is required to be active. If you mark the OS partition as active, your windows will not be able to boot.

Sorry, it was my mistake in writing the note, but not in the actions I took. Disk 0 and Disk 1 ARE disabled in the Bios. Disk 2 System Reserved is, in fact, Active as you can see below:

2021-10-28 (1).png

It now boots without showing the light blue screen with the options "Windows" and "Windows Pro", but it still doesn't allow the mbr2gpt because "Cannot find OS partition(s) for disk 2".

@Bob Arthur 
Yes, I can see that disk2 (465.76GB) has an active partition. However, your computer has failed to load the operating system from disk2, it might be a configuration issue in BIOS. Once the OS is loaded from disk2, the system will take drive c: from the same disk (465.76GB).