Problems installing a driver on Windows 10

Highlighted
Deleted
Not applicable
I have an ICOM 7300 Amateur Radio Transceiver which has a USB port, for computer connection. Am currently running Windows 10 Operating System on an HP Desktop computer.
I intend to use the USB cable for rig control using the Ham Radio Delux software, as well as digital modes, which all require a functional USB connection to a computer.
 
I am experiencing problems with the installation of a Virtual Port (VP) to connect my USB to UART. I have installed recommended Silicon Labs CP210x driver, downloaded from the official Silicon Laboratories website. I am using the recommended CP210x drivers version 6.7.0.0 for the VP and give an error message Code 10. it won't work. When l click on device manager the com virtual port allocated for the USB to UART bridge has a yellow exclamation mark. I have also reset the VID and PID as recommended in some forums.


What is interesting is that the installation has created two OEM.inf files (OEM28.inf and OEM40.inf) and both seem to be in use. I have noted that the system registry does actually recognize both files as active drivers for the silabvcp.inf. I have further tried to uninstall the Silicon Lab drivers and delete these OEM files with silabenm.sys and the associated files and fails to delete as they are in use.
I have also tried to uninstall the silicon lab software/program and cannot be located in features and programs so that l could delete the above files manually.

Please can you advise me how you resolved this vexing problem thatI have been grappling with for the past six months.

 

So, the problem appears to be essentially one of Windows not accepting or loading the driver, when this is done and the com port created, the rest should (hopefully), be relatively straight forward.
 
Please note that I have, over the past six months, attempted to install the CP210x driver on various laptops and desktops, on Windows 10 Pro as well as Windows 8.1, and always experience the same problem (driver installation failure).
 
I have installed TeamViewer and am quite happy for you to log in remotely and have a look at the problem.
 
 
2 Replies
Highlighted

was there not a resolution for the viewing public ?

Highlighted

Sorry this wasn't answered! I'm moving it to the Windows 10 space for better visibility.