Pointing devices disappeared from within Device Manager.

Copper Contributor

I had an issue I'd never seen before happen to one of my Windows 10 machines, and I wanted to share as I have not seen any posts on any communities that came to the same solution I had for a mouse issue.  I tried to respond within other threads, but most were locked down saying they were resolved.  Well, none of their resolutions fixed my issue.

 

I have multiple Win 10 PCs, two of which are desktops I built from scratch.  Both were built together and upgraded to Win 10 at the same time, both with auto-update enabled on the exact same schedule.  The hardware is essentially identical, but more importantly, the keyboard and mouse were the exact same.  Yet one PC lost mouse response.  I used the PC in the morning working on a PowerPoint presentation, stepped away for a hour, then came back to find my mouse was not working.  I was using a Logitech M530 with a K350 Keyboard via a single USB unifying receiver.  The keyboard was still working, but the mouse was not.  I took out the batteries and tested them, and both were good, but I still switched out for new batteries.  Nothing.  I switched USB ports.  Nothing.  Then I took out a different USB wireless mouse and connected it.  Nothing.  I then went old school and pulled out a corded PS/2 mouse and connected it.  Nothing.  I rebooted...multiple times during many of these efforts.  Nothing.   After over an hour of messing around, including reloading the Logitech software, I still had nothing. 

 

Then I went into Device Manager to try and reinstall my mouse drivers, the "Mice & other pointing devices" section was gone.  In it's place was an "Other device" with 2 USB "unknown device" items that Windows could not find the right drivers for.  There was a keyboard section, and even a "Human Interface Device" section which listed a "Logitech USB Input Device".   I right-clicked and had it check for updated drivers...but the most current version was loaded.  I'm pretty versed in Windows after 20 years of using platform and even building deployment images for it a while back....but I was baffled.  I ended up calling Microsoft support who went through many troubleshooting efforts with me.  In the end, I needed to perform a full Windows upgrade to correct the issue.   

 

A frustrating event to say the least, but I'm glad the upgrade fixed it without me having to do a reinstall.  Not sure if this was a unique incident, but wanted to share in case any others had similar failures with the other solutions.

 

BTW...the most painful part of this entire event was the rusty nature of my Windows shortcut key muscle memory.  I had no idea how completely reliant I've become on that darn mouse!  Guess I'd make a horrible Unix admin ;)

23 Replies
Thank you Rachel Tait
I was struggling with the same issue and your solution worked for me.
Thank you

@Jeff Bovee I tried each and every mentioned solution but nothing worked. I tried installing driver from google also but failed again and I was not ready to reinstall my windows so I tried the next steps and surprisingly they worked. In device manager under view, there is an option called SHOW HIDDEN DEVICES. Click on that and then you will see your mice and other pointing devices option and under it your driver. Just uninstall it and restart your pc, your touchpad will start working.

Some time the pointing mouse disapear due to display option
Press windows logo + P
And check the display option
Chose computure monitor only
Cause some time you change the display option to external monitor by mistake
Had the same issue, I was searching for a solution and saw your reply, had seen the same 'I2C HID Device' having an error code. then went back to Device managers and did what you did, boom, problem solved.
Thanks!!