Pointing devices disappeared from within Device Manager.

Copper Contributor

I had an issue I'd never seen before happen to one of my Windows 10 machines, and I wanted to share as I have not seen any posts on any communities that came to the same solution I had for a mouse issue.  I tried to respond within other threads, but most were locked down saying they were resolved.  Well, none of their resolutions fixed my issue.


I have multiple Win 10 PCs, two of which are desktops I built from scratch.  Both were built together and upgraded to Win 10 at the same time, both with auto-update enabled on the exact same schedule.  The hardware is essentially identical, but more importantly, the keyboard and mouse were the exact same.  Yet one PC lost mouse response.  I used the PC in the morning working on a PowerPoint presentation, stepped away for a hour, then came back to find my mouse was not working.  I was using a Logitech M530 with a K350 Keyboard via a single USB unifying receiver.  The keyboard was still working, but the mouse was not.  I took out the batteries and tested them, and both were good, but I still switched out for new batteries.  Nothing.  I switched USB ports.  Nothing.  Then I took out a different USB wireless mouse and connected it.  Nothing.  I then went old school and pulled out a corded PS/2 mouse and connected it.  Nothing.  I rebooted...multiple times during many of these efforts.  Nothing.   After over an hour of messing around, including reloading the Logitech software, I still had nothing. 


Then I went into Device Manager to try and reinstall my mouse drivers, the "Mice & other pointing devices" section was gone.  In it's place was an "Other device" with 2 USB "unknown device" items that Windows could not find the right drivers for.  There was a keyboard section, and even a "Human Interface Device" section which listed a "Logitech USB Input Device".   I right-clicked and had it check for updated drivers...but the most current version was loaded.  I'm pretty versed in Windows after 20 years of using platform and even building deployment images for it a while back....but I was baffled.  I ended up calling Microsoft support who went through many troubleshooting efforts with me.  In the end, I needed to perform a full Windows upgrade to correct the issue.   


A frustrating event to say the least, but I'm glad the upgrade fixed it without me having to do a reinstall.  Not sure if this was a unique incident, but wanted to share in case any others had similar failures with the other solutions.


BTW...the most painful part of this entire event was the rusty nature of my Windows shortcut key muscle memory.  I had no idea how completely reliant I've become on that darn mouse!  Guess I'd make a horrible Unix admin ;)

23 Replies
I thought I would share my solution to this problem. Had this issue on a laptop where i booted it up and no mouse! Looking in device manager there was no 'mice and other listed. However, under Human Interface Devices the 'I2C HID Device had an error code. Attempted to update it but it had the latest drivers. I disabled and enabled it and my mouse reappeared along with the mice and other option in device manager. Totally strange!

I had something similar, but it was the whole "sound, video and game controllers" that disappeared. I used the inplace upgrade process to fix it.

Thank you sooooo much for this. After an hour and a half and several unsuccessful 'fixes,' from other sites, this one worked. Cheers!

I've had this problem for awhile but that fixed it. Disabled it restarted it and the was the mouse back in device manager. Thank you Ron

Hi Jeff,

Trying to find a solution to the exact same problem you describe, I came across your message.

I found your message discouraging and switched off my PC and went to watch TV... :)

After a sleepless night, I realized that I had done a backup a month ago (mirror) of my drive C using a freeware utility that I have been using for years called "Compare Advance".

=> https://www.bauerapps.com/compare-folders-windows-compare-advance/

After a first coffee the next morning, I fired up my PC and "fingered" myself through to the menus to my "C:\Windows" and "Backup C - C:\Windows" folders in "Compare Advance".

There was a discrepancy in the number of files so I copied missing files from the backup back to my "C:\Windows".

After this exercise that took about 10 minutes I restarted Win10 and like a little miracle the cursor and the blue turning circle had reappeared and the mouse was working fine again.

Scanning through the registry HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS I found many entries regarding the cursor, one entry that said "enable cursor hiding" or something like that was set to 1; I set it to 0 in the hope to prevent the initial problem.

I am happy that I do backups regularly using "Compare Advance" and that I was able to solve this problem by myself.

I am convinced that "to perform a full Windows upgrade to correct the issue." that you "needed" to do, was the eagerness of a Microsoft technician to try and find the reason for the problem.

Had he asked you to get out a backup of your drive C, which I am sure you have as an experienced user, the problem could have been solved without a big fuzz.

In my experience, I have done a lot of damage trying to find the reason for a problem instead of fixing it.

As you all know, sometimes the weirdest PC-problems happen for no apparent reason and it is useless to try and chase some esoteric reason. :) 

Electricity and the shoving around of electrons is a weird science in itself... most of the time it works and when it does not, fix it. :)

Backups of working systems are the key to troubleless computing.

In that sense: Happy computing!


I am trying this but after my trackpad is disabled I cannot get the directional keys to work to restart, and simply reenabling does not solve the problem. Any suggestions?

@Jeff Bovee 

Just wanted to send big appreciative covid-free hug from New Zealand to say thank you so much for posting your story as I had the identical problem and couldn't find how to fix it. Spent hours doing all the things I was advised to do but no joy. Why the pointing devices had disappeared I don't know but I had the Logitech USB listed where my mouse stuff used to be. Weird but I did the full Microsoft upgrade - which also took hours - but immediately after Reboot the mouse started working. Yay! I am not tech savvy at all, and If I hadn't found your story either me or the PC would've gone out the window!

Anyway take care. Much appreciation :D



I have exactly the same problem an used to deal with Windows issues for at least  decades but no luck so  far.


This issue is so weird, don't know what broke the mouse stuff but that was a powerful trick.

Having to reinstall windows for that is a long pain but I'll have no choice if the last 2 things to check failed.


@Rachel Tait Thank you Racheeeeeeeeeeeeel! OMG I thought I was good with computers, but I had no external mouse at hand and got the Ease of Access numpad mouse controls running. I uninstalled and downloaded 15 different drivers while I was dumbfound by the fact there was no mouse in device manager. Thank you so much for your input, I feel like I would have never solved this thing without your help! I even tried fidgeting around with the Human Inteference Devices HID thingy, but since nothing worked I went on to download more drivers. I feel like you gave me back an important limb, THANK YOU! and thanks @Ron0995 for the tip to restart after disabling. You two solved a puzzle I was unlikely to solve in 100 years!

Edit: Bold tl;dr text for the people of future in the same mess.

I've been having a similar issue, except instead of the entire "mice and other pointing devices" missing specific mice have been moved to "other devices". only the rgb lights work. I have a single mouse that is still in the "mice and other devices" but all other mice are automatically put into "other devices" and do not function. I'm not very tech savvy, and I understand that this may be unrelated to the initial post, but I've been researching all day and this is the only post that I could find that is even similar to my problem. Please help.

Thank you sooo much...after attempting all that was said online, this worked:woman_dancing::woman_dancing: such a relief

@Jeff Bovee Sadly, none of the above solutions worked for me, however, something much simpler did recover it. If you have an extra mouse, connect that one. If you have a Bluetooth mouse, then 'forget' the device, and then reconnect. I believe this worked because when loading up a mouse, in the Action Center it does say that it is setting up the mouse. Both solutions fixed it for me, however, this solution may be inapplicable to users of wired mice. 


Unfortunately i am facing similar problem but i am not sure what do to now. 

I was using a brand new Logitech M235 mouse since 2 weeks and suddenly to my huge disappointment, 3 days back it stopped working. I tried changing batteries etc but no joy. Also I see that the mouse is not reflecting in device manager. I mean there Mice and other pointing devices is displaying but Logitech mouse is not reflecting in its expanded items. I tried connecting other mouse also, even that's not displaying. Someone suggested Microsoft upgrade? I am sorry but how to do that? My windows say its up to date with the updates. I am having a hard time with this as i really need mouse for my work. :(  Someone Please help !!  

@Akank700 Does it appear in Windows Settings or the Action Center when you plug in the USB receiver (presuming off searching your mouse) in? If 'Mice and other pointing devices' appear, that does mean that your device is working, yet there are no solutions, from my limited scavenging, that deviate from this thread. If you haven't attempted every solution within this thread, please do so, and if all else fails, browse the Internet for some more solutions. 



I have an Acer that we just updated to win 10 from 8.1. Lost the touch pad. Device manager has no mouse /pointer and under the human interface I have like four other choices not the IC2. Any suggestions. Tried F7/9 with and without function key, ready to throw this thing through the window lol
So fixed. Had to go into the bios and select basic instead of advanced - let driver kick in and touch screen still works!
I have had this issue on and off for a few months now and have not been able to find a solution, yours worked first time, thank you.