Operation could not be completed (error 0x00000005) when Eg. trying to change default printer

Copper Contributor

Problem occurred after updating to 1803. This solves the problem (or actually, did in my case)


1. Regedit

2. Go to: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

3. Backup/Export the Windows reg folder

4. Right click on Windows folder and select Permissions…

5. Here check the Full Control permission for Your user under Allow option. Click Apply > OK to save changes.

6. Delete these following registry under HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows (I only had Legacy+User, not device) 




7. Reboot


Just wanted to let You know. Really annoying problem........





2 Replies
Bit late to the party, but I just had this issue for a computer trying to print to a network printer after an OS update. After an hour of researching the issue, this was the solution that worked!
In my case, using Windows 11, the way I solved it without changing the Registry Editor, was by adding the printers as admin. I opened an explorer window as an administrator (from an administrator terminal/console), then I accessed the remote printer, "connected" to it, and voilà, I am no able to print to it from my PC (again).