OneDrive issues after update to Windows 10 2004

Copper Contributor

I recently updated Windows 10 to version 2004, and after the last update-related reboot OneDrive would keep complaining about not being able to connect to Windows--required for the Files On-Demand feature (see snapshot below). 


OneDrive cannot connect.png


I tried both workarounds related to cldflt.sys described in this Support article, but in my case both were checking out fine.  I finally gave in & clicked Download Files, which was supposed to disable Files On-Demand and just pull down everything that wasn't there already.  But the sync gets stuck immediately, claiming that it's downloading 1 out of 35 files (18MB total), except no matter how long I leave it, or how many times I restart OneDrive or logout & back in or restart the entire machine, it never moves forward...


OneDrive downloading.png


To make matters worse, none of the files synced to OneDrive now open; I am using OneDrive to backup Desktop, Documents, and Pictures, so none of those files can be opened...  Here is an example of a message thrown when trying to open a PDF on my Desktop (which, by the way, is fully sync'ed, as indicated by the green check overlay on the file's icon):


OneDrive cannot be accessed by system.png


Any ideas how to get out of this pickle?   

54 Replies

Same question. This problem suddenly happened on yesterday. My system version also is 2004. Have you solved this problem, sir?

No fix at the moment, I too have opened a Microsoft support case to see what can be done

@HughesHall ok, I can only wait for Microsoft to fix it...

The issue has been escalated to the next level of support
I also have the same problem, having updated to 2004 yesterday. Serves me right for breaking my own cardinal rule of never updating for at least 6 months to give MS the time to fix all the bugs. Let's hope we have a solution soon!
best response confirmed by MStruzak (Copper Contributor)



Hi, please check \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CldFlt\Instances


After upgrade to build 2004, the DefaultInstance was set to CldFltUpper. 


I changed the value as CldFlt, rebooted... And now the FOD function is back and fully functionnal.


Hope this will work for you too. 


I had the idea to change this value as on my professional computer, I only have one instance named CldFlt and not the CldFltUpper. 




Solved my problem :) Thank you for posting!

@Josep1190 This didn't fix my issue as the OneDrive app will not even run on the PC

After changing the key, it still would not run


Hi, sorryn but my replie and solution was for @MStruzak  who described my exact same problem. You said in your post yours is slightly different. 

Good luck solving your issue. 


It worked for me, problem fixed, thank you so much!! :)


you're welcome !

@Josep1190Below is a snapshot of the registry on a machine that upgraded successfully with the DefaultInstance set to CldFltUpper. The problem must be elsewhere.






@Hammer_Man Hi, sorry it does not help you. But as said to @HughesHall my reply and solution was for @MStruzak  who described my exact same problem. You said in your post yours was the same as @HughesHall, which is not mine. At least two users solved their problem using my trick.

Good luck solving your particular issue. I knows each situation is unique.

OMG, thanks, sir! solved this problem!!!!

We found the solution to our issue of OneDrive not starting, it was the InTune Shared Desktop policy that is an on or off setting but it set 30 policies up including disabling OneDrive!

Why you'd want to disable OneDrive on a Shared Desktop in a InTune environment, I don't know but here is the article on what this policy does:

Gotcha! Just one of the numerous setting this one policy makes

Admin Templates>Windows Components>OneDrive

Prevent the usage of OneDrive for file storage




@Josep1190, you're a Genius!  My \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CldFlt\Instances was also set to CldFltUpper, and although I did not have a pre-upgrade copy to compare, I just followed your recommendation: changed to CldFlt & rebooted.  Now everything works again! 


Thank you very much!  

Hi, Glad it helped you !

I hope someone from Microsoft will explain why this happenend ??...
your a genious!



It works for me too ! File On-Demand is now working !

Thanks a lot.