OneDrive issues after update to Windows 10 2004

Copper Contributor

I recently updated Windows 10 to version 2004, and after the last update-related reboot OneDrive would keep complaining about not being able to connect to Windows--required for the Files On-Demand feature (see snapshot below). 


OneDrive cannot connect.png


I tried both workarounds related to cldflt.sys described in this Support article, but in my case both were checking out fine.  I finally gave in & clicked Download Files, which was supposed to disable Files On-Demand and just pull down everything that wasn't there already.  But the sync gets stuck immediately, claiming that it's downloading 1 out of 35 files (18MB total), except no matter how long I leave it, or how many times I restart OneDrive or logout & back in or restart the entire machine, it never moves forward...


OneDrive downloading.png


To make matters worse, none of the files synced to OneDrive now open; I am using OneDrive to backup Desktop, Documents, and Pictures, so none of those files can be opened...  Here is an example of a message thrown when trying to open a PDF on my Desktop (which, by the way, is fully sync'ed, as indicated by the green check overlay on the file's icon):


OneDrive cannot be accessed by system.png


Any ideas how to get out of this pickle?   

54 Replies

Just an update for those who, like me, might be trying different things to get this to work again...  Here is what I just heard from Support:

Apologies for any trouble caused. Yes there is an ongoing issue with that 2004 update and many users are affected with it but hopefully the engineering team will have this fixed soon as they are working on it and let's further wait for the next update.   

BTW, Onedrive sync client ver. 084 doesn't fix it--already tried...  

Sounds like something I had seen before , MS has a workaround for this issue, although yours can still be related to some "nastiness" in the latest build.

@MStruzak Same problem here.....

@janvanwaeyenbergh You have linked to the same article the OP linked to where he said he had already tried that.

@MStruzakI have heard talk of a fix being worked on. In the meantime, I fixed it by doing the following:


Make 2 complete backups of everything in my OneDrive, one by copying everything in the OneDrive folder on my second PC where OneDrive still works (Windows 10 2004 has not yet been installed on there), and also by downloading everything from the OneDrive website to my main PC.

Close OneDrive app

Reset OneDrive -

Delete everything in the OneDrive folder

Restart OneDrive

OneDrive then synced everything successfully.


If I then re-enable Files-On-Demand, I once again get the error "OneDrive cannot connect to Windows".

If I choose “Download Files”, as I did before, it seems to work – for now.

@arganoid Yep same results but still has the same outcome.  I want to use FOD and I cant!

due to OneDrive sync issue ( cant open , edit , copy any file in the local pc ) you need to restored to earlier build version of windows (from 2004 to 1909) until the issue solved

far from ideal! Is this an official MS response?

Same problem here...


I also tried running  this:

%localappdata%\Microsoft\OneDrive\OneDrive.exe /reset


But no success. When activating the On-Demand Files it still shows the same message, with the error code 0x80070032

@MStruzak We have a slightly different issue but the same cause. We have OneDrive KFM configured and we rolled out 2004. We found that Dell OptiPlex 7070 would not connect to OneDrive but other models work without issue. All our HP worked fine, Dell 9020, 7040,7050 & 7060 are fine too.

We have tried everything but we can't get One Drive to work.

I wonder why that hardware has an issue and does this point to the root cause? We have 30 identical PC's that don't work. BIOS and all drivers up to date.

I had the same problem as @HughesHall.  Two Acers and two HPs were upgraded and this problem appeared only on one of the HPs. I was able to roll that one back to 1909 but I had to reinitialize OneDrive after the rollback. There is one more HP to upgrade, but I am holding off until this issue is resolved.


Is there a way to be notified when a resolution is published?

@Hammer_Man I dont think anyone from MS has posted here or acknowledged the problem.  They may not be even aware....  Has anyone raised a support case?

@Resonate1740 I raised a support case (2117010) shortly after writing the OP--check my first reply in this thread, with one of MS replies verbatim.  I must say, the way MS handles tickets is rather obscure.  My original concern was answered by a virtual assistant, then passed onto a live expert (I guess that's when the ticket was open), but I don't see a way to check that ticket's status or even see my exchange with the expert (all done inside a chat-like interface from  

We have premier support through enterprise.  Ill give it a go there and keep you posted. @MStruzak 

I replied to an email from Support, and got an answer back asking for very basic details, as if my entire exchange with the "expert" the other day was not part of the ticket at all.  I brought them up to speed on everything, will see what they say...  

@MStruzak I’ve also noted that although all my environment is deployed via Intune and my office apps are set to current preview, I seem to have a much newer OneDrive client than the desktops with issues. I seem to have an insider update of 20.103.0521.0002 while the others have 20.064.0329.0008 Or older. All the office Apps are up to date on both machines and the same with windows updates. Why does this one surface laptop that KFM works on have a insider version?

i can’t find a download to try on other machines.

@HughesHall I just managed to install 20.103.0521.0002 by selecting the insider button in OneDrive settings.  However, it has not fixed the issue.

@HughesHallTwo computers that I updated had the same version of OneDrive. The error occurred only on one, so I think it is a Windows Update problem, not with OneDrive.

@Resonate1740 Thanks for the update, it seems there is no obvious reason for the issue. It works on some machines and not others.

We now have user who it works for but not others on the same machine!


1 best response

Accepted Solutions
best response confirmed by MStruzak (Copper Contributor)



Hi, please check \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CldFlt\Instances


After upgrade to build 2004, the DefaultInstance was set to CldFltUpper. 


I changed the value as CldFlt, rebooted... And now the FOD function is back and fully functionnal.


Hope this will work for you too. 


I had the idea to change this value as on my professional computer, I only have one instance named CldFlt and not the CldFltUpper. 




View solution in original post