.net framework 3.5 installing error 0x8007002

Copper Contributor

i am trying to insrtall .net framework 3.5 (includ 2.0 and 3.0).After downloading files,it gives error0x8007002, specified files not found.

Found some solutions on internet but didn't work.Some experts past replies on 0x8007002 error all did't work.One solution that everybody mentioned was to download window 10 iso.GO to source\sxs and copy microsoft-windows-netfx3-ondemand-package file and paste it in C: drive and from admin cmd type Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:C:\ /LimitAccess.

but it also didn't worked.

Tried everything but its not enabling.

checked the windows updates and its updated.

any solution?

15 Replies


Hi @shari210,


Could you try that?


1. Mount the ISO of the Windows 10 which version you are using.

Mount ISOMount ISO

D(ISO Drive)\sources\sxsD(ISO Drive)\sources\sxs


2. Open Command Prompt via Administrator rights.

3. Run "Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:D:\Sources\sxs /LimitAccess" command.






@hasanemresatilmis I Have tried it and its still not working.


Here is the dism: https://drive.google.com/file/d/1FSXeYNTnQY3FH3lhXdsdEuLB2P0Iy5t0/view?usp=sharing


Hi @shari210,


I think that error occurs after installation of KB4074590 (KB number can be different for version of OS). Could you check that update?


And you could try that please?


1. Run the command "sfc /scannow".

2. Run your installation command again with /restorehealth option 

"Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:D:\Sources\sxs /LimitAccess /restorehealth

@hasanemresatilmis its still not working same error.

Screenshot (53).png

this cmd method you told not worked


@hasanemresatilmis and there is no such update you mentioned

Screenshot (54).png



What happens when you run

Add-WindowsCapability –Online -Name NetFx3~~~~ –Source D:\sources\sxs


Instead of using dism? 

I Didn't run it. what is the full command?


Hi @shari210,


What is the version of your OS? 

os version is 2004



I opened a admin powershell: Add-WindowsCapability –Online -Name NetFx3~~~~

so with the 4 ~


Hi @shari210,


Could you try these commands with same order?


sfc /scannow

DISM /Online /Cleanup-Image /RestoreHealth

Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:D:\Sources\sxs /LimitAccess


@hasanemresatilmis It took too much time but still same result

Screenshot (55).png

Hi @shari210,


You've get an error on second command (DISM /Online /Cleanup-Image /RestoreHealth).


Firstly, we have to solve that. Could you run one of the following commands, depending upon whether you have install.esd or install.wim in the Sources folder in the Windows 10 setup disk.


Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:E:\Sources\Install.wim:1 /limitaccess




Dism /Online /Cleanup-Image /RestoreHealth /Source:esd:E:\Sources\Install.esd:1 /limitaccess



Hi @shari210,


Your Windows ISOs are on "F" and "K" drives . But you typed "E" on command.