July 12, 2022—KB5015807 (OS Builds 19042.1826, 19043.1826, and 19044.1826)

Occasional Contributor

Hi,

since installing July KB Internet Explorer Mode (IE Mode) does no longer work.

https://www.reddit.com/r/edge/comments/vy5ety/ie_retirement_emie_site_list_suddenly_not_working/

 

Can't really find any more information in the matter. Tried to uninstall the KB & tried the Known Issue Rollback, does not help.

 

A site that normally opens in IE11-mode in Edge-chromium now only opens in Edge and does not work accordingly.

 

https://support.microsoft.com/en-au/topic/july-12-2022-kb5015807-os-builds-19042-1826-19043-1826-and...

 

/BR Mattias

22 Replies
Have you tried updating the Microsoft Edge too?
Have you tried adding it to the list?
You may navigate to edge://settings/defaultBrowser and add it.
Hi Reza,
Version 103.0.1264.49 (Officiell version) (64 bitar)
We're using the latest Stable channel version. I've also trided Canary which is on Version 105.0.1320.0 (Officiell version) canary (64 bitar).

They are both showing the same symptoms.

Yes, adding it to edge://settings/defaultBrowser just causes the page to not even open, it just ends up trying to load but nothing happens.

/BR Mattias
Does it happen for other websites too?
I advise you to visit the website and press Alt+Shift+I and report this issue.
It happens for all sites you add to the list.

Hi @MattiasB3 

Please this is the official information provided by Microsoft, I hope it will be helpful:

Internet Explorer 11 has retired and is officially out of support—what you need to know | Windows Ex...

" Some websites only work with Internet Explorer—these websites might be built on older internet technology and not function properly while using a modern browser. Understanding this, we’ve built Microsoft Edge with IE mode. "

"

As a business, you can set up IE mode to use a site list, where you can catalog those sites that require Internet Explorer and have them load automatically in IE mode. You can store this site list locally, or in the cloud through the Microsoft 365 admin center, and any site on the list will load for your users in IE mode. This is the recommended approach if you’re a business that manages your devices and has legacy requirements.

"

@Andrzej1Hi Andrzej1, if you read my first post, I'm stating that we're already using IE11 in Edge. This is however bricked since Julys' KB.

@MattiasB3 

Yes, but you can check the help possibility that is in the shared article, as well as your post should change the location in the Edge Insider space.

"We have help along the way if you experience compatibility issues when testing your websites in IE mode. You can get no-cost remediation assistance for those issues from our App Assure compatibility experts by submitting a request for assistance or by emailing us at "

`

Do you have any extensions in the Microsoft Edge?
If yes, try disable them and try again.
Make sure report this issue using the feedback option.
In this case, make sure file feedback report , so the Windows team will investigate it.
Hi,
was in contact with Microsoft, they have multiple cases of the same issue, patch breaking IE-mode. They're looking into it.
Thank you for the update, hope for the release of the fix.
Meanwhile, I notice it has been mentioned on the website, have a look at:
https://support.microsoft.com/en-us/topic/july-12-2022-kb5015807-os-builds-19042-1826-19043-1826-and...
The solution is to use Known Issue Rollback as workaround.

@Reza_Ameri 

The KIR has been on the site since the release, it does not help at all with the issue - already tested.

 

/BR Mattias 

Has anyone been able to find a work around for this? Logged a call with Microsoft Support and waiting to hear back from them but figured I would see if anyone has figured a way around it.
Hi EdwinLJ,
using a computer pre-patch KB5015807 is working. I know of no other work around. You can't downgrade if the patch is already installed - it will not help.

/BR Mattias

@MattiasB3 Microsoft have come back to us and said they are looking into the cause for now they have provided a couple of possible work arounds I have used the NeutralResources via Intune Policies rather than GPO but the result should be the same.  My users can now access the few URL's we need to work via IE computability mode.  I dismissed the option of disabling Edge MDAG completely however we did test that on a test device and it also fixed the issue so seems to be something in the MDAG isolation policies causing the issue post patch.

Add the sites in the IE Mode list as trusted in the Network Isolation policy. On the gpedit the path to the polices -> Computer Configuration\Administrative Templates\Network\Network Isolation.

  1. For intRAnet sites, you’ll need to add their IP addresses & the corresponding Network Domains to EnterpriseIPRanges (Network Isolation\Private network ranges for apps) & EnterpriseNetworkDomainNames (Intune only) policy
  2. For intERnet sites, you’ll need to add their domains to either EnterpriseCloudResources (Network Isolation\Enterprise resource domains hosted in the cloud) or NeutralResources (Network Isolation\Domains categorized as both work and personal) policy

OR

                  Stop targeting Edge MDAG policies to those machines

 

Hope this helps you.

Thanks @EdwinLJ I can confirm the workaround of removal the MDAG policies fixed our issue. In our case the policies were not correctly implemented by a project and we were planning to remove them to start a fresh.

@EdwinLJ  Thanks so much.  Our Edge would go in to IE mode and show a 'cannot connect' error.  If you refreshed, it wouldn't use IE mode but show the webpage.  If you refreshed again it would go back in to IE mode with a 'cannot connect' error.  We have been running with the same configuration for months with no issues.

 

I can confirm that this fixed it for us.  I would never have found the cause of this!

Did you configure the GPO/Intune policies or just disabled MDAG policies? Having the same problem but cant get those intranet sites working..